DWA-131 Revision E - Never gonna give you up

Hi everyone, I’ve tried every trick in the book with my Element14 Beaglebone Black Rev C can’t even get a wlan0 going.

uname -r
3.8.13-bone50

lsusb

Bus 001 Device 002: ID 2001:3319 D-Link Corp.

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsmod

Module Size Used by

g_multi 50407 2

libcomposite 15028 1 g_multi

mt7601Usta 641118 0

Tried upgrading my kernel but getting a 404 when using the /opt/scripts/tools/update_kernel.sh

Also can’t connect to the web via USB due to some weirdness in Yosemite, actually installed Ubuntu on a VM to bypass it, which worked but it’s a pain.

Does anyone have any ideas? D-Link has Linux drivers and instructions at: http://support.dlink.com.au/Download/download.aspx?product=DWA-131&type=Drivers

Here are the instructions, which don’t work:

Ubuntu 10.04.2

Install:

  1. tar zxvf 20140812_rtl8192EU_linux_v4.3.1.1_11320.tar.gz
    and cd to 20140812_rtl8192EU_linux_v4.3.1.1_11320
  2. make
  3. su-> enter your root password
  4. make install

Last time I connected it to my BBB the wifi dongle led lit up and blinked for a second then went off. If I run ifconfig the BBB hangs.

Wow DLINK Has Linux driver’s for the ARM SOC ? I suppose they realize their will always be someone who keeps trying to use their products on hobby board’s huh ? without buying one that comes from a list is well supported my the hobby board . And if they make that one user happy it will lead to a life long customer. Nice

You need to update the /opt/scripts/ directory..

cd /opt/scripts/
git pull

Regards,