Edimax 7811UN as Access Point

Ok I know the web is full of this kind of stuff I apologize in advance, however I believe I have just about tried it all.

Is there an idiots guide to get this Realtek 8188CU chipset working as an Access Point?

I have tried to build any number of hostapd versions - all fail to build. Usually due to issues around ‘modules’. I have downloaded sources, headers etc to no avail. Current sources at linux-3.8.13-bone43 and headers linux-headers-3.8.13-bone43

Even found a bash script that took me through the process and filled out hostapd.conf to my requirements and installed everything - didn’t work.

I am running Debian

uname -r gives 3.8.13-bone43

Has anyone found a pre-built ready to install version of the driver and the hostapd for debian? - for dummies like me!

Thanks in advance

AP

Hopefully you have had success. If not, I was able to use the instructions here for a Realtek 8192cu:
http://wiesel.ece.utah.edu/redmine/projects/hacks/wiki/BeagleBone_Black_AP
I did get access point up and running. You need a modified hostapd or you have to compile it yourself with modifications. Overall it is a royal PitA.