EMMC to SD backup not workinig

HI people,

I have a BBB rev C for my playing around and i forgot the password. I tried to use the https://elinux.org/BeagleBone_Black_Extracting_eMMC_contents to extract the emmc to sd card and see if i can change the shadow file and gain access to my BBB again. - I just inserted the sd card and it booted to it no S2 button press

When i tried to put the SD card. the dd command gave me like 20 byte empty gz file.
I tried to modify the autorun script to print the /dev to a file and found there is no mmcblk1 - Which means emmc is not even detected.

how i make sure the emmc is detected from the sd card boot and extract the emmc content???

Is it something to do with new revision??

help please… all my work is inside :(((

Hi
I have done similar on other board. Following steps may helpful
1. Boot from sdcard
2. In shell(uart or ssh terminal) execute lsblk
    It will show mmcblk0(maybe flash), mmcblk1(sdcard?)
3. Plug usb thumb-drive and mount it
4. sudo dd if=/dev/{eMMC flash block. Maybe mmcblk0} xxxxxx
    Use dd command to extract flash disk to img file.
5. Access img file in other linux pc.
    You can use loop0 or img mount in host and can see inside.

Regards