eMMC won't flash

Supposedly just holding the boot button down flashes the OS from the SD card to the eMMC? I tried this, and I left the board for ages and nothing happened. I tried it again, holding the button longer. Simply nothing happens. No feedback from the LEDs - they just flash as they normally do.

I’ve got a 32GB sd card with Ubuntu 14.04 on it. The partition size is 30GB but I’m using 1.7GB. So, my goal is to copy over the contents, ideally without having to reinstall anything - I have software installed that took all day to build (gstreamer) and I had to delete the source directory to trim down to below 2GB.

Anyway, frustrating because the wiki seemingly lied to me. There’s no available documentation on this flashing feature if it exists.

How can I flash it over?

Hello,

I am using NHD-7.0CTP-CAPE with BeagleBone Black with UBUNTU 14.04 Kernel 3.15 (image supported by NewHaven).

Ubuntu is running from SD Card and I would like to flash the image to eMMC.

I’ve tried to use some sripts, but no one them worked out:

https://github.com/RobertCNelson/tools/blob/master/scripts/beaglebone-black-copy-microSD-to-eMMC.sh

/opt/scripts/tools/eMMC/beaglebone-black-make-microSD-flasher-from-eMMC.sh

Did anybody manage to flash the eMMC on Ubuntu 14.04?

Thanks,

Márcio