Enable UART1 on BBB under Ubuntu (13.04)

Yo experts, I am having problems transitioning to the BBB. After I installed Ubuntu only uart0 (/dev/ttyO0) seems to be enabled. How do I enable uart1 (tx: p9-24, rx: p9-26, /dev/ttyO1)?

I have found the following links …

http://blog.pignology.net/2013/05/getting-uart2-devttyo1-working-on.html
http://hipstercircuits.com/enable-serialuarttty-on-beaglebone-black/

… but I am still not sure how to do this. For one I can’t find the devicetree files (/boot/am335x-boneblack.dtb, etc). I am also confused about the fact that these guides seem to match uart2 to /dev/ttyO1. How does this make sense?

Help and pointers appreciated,

-stefan

Yo experts, I am having problems transitioning to the BBB. After I installed
Ubuntu only uart0 (/dev/ttyO0) seems to be enabled. How do I enable uart1
(tx: p9-24, rx: p9-26, /dev/ttyO1)?

I have found the following links ...

http://blog.pignology.net/2013/05/getting-uart2-devttyo1-working-on.html
http://hipstercircuits.com/enable-serialuarttty-on-beaglebone-black/

... but I am still not sure how to do this. For one I can't find the
devicetree files (/boot/am335x-boneblack.dtb, etc). I am also confused about

it should be under:
/boot/uboot/dtbs/*.dtb
&
/boot/uboot/zImage

otherwise it isn't my image..

the fact that these guides seem to match uart2 to /dev/ttyO1. How does this
make sense?

It makes perfect sense... Kernel starts counting at 0.. TI datasheet does not..

Regards,

Thanks for the quick answer …

it should be under:
/boot/uboot/dtbs/*.dtb
&
/boot/uboot/zImage

otherwise it isn’t my image…

I see, I’ll have to double check, maybe I got an obscure kernel :wink:

It makes perfect sense… Kernel starts counting at 0… TI datasheet does not…

So what about UART0 on the 6 pin header? Also the old BeagleBone/Ubuntu would map UART1 to /dev/ttyO1. Am I confusing something?