Enabling DSP mem argument with uEnv.txt?

Hi,

I’m trying to run C6Run package on my Beableboard-XM with Angstrom environment.
Building was O.K. I got stuck at the u-boot boot arguments passing.

According to the instruction in http://www.angstrom-distribution.org/demo/beagleboard/ I have to add ‘mem=99M@0x80000000 mem=384M@0x88000000’ to the bootargs. However, in the new u-boot environment that using uEnv.txt file, I can’t manage it properly.

I tried this;
mpurate=800
dvimode=1280x720MR-16@60
vram=12MB
bootargs=console=ttyO2,115200n8 console=tty0 root=/dev/mmcblk0p2 rootwait ro vram=${vram} mem=99M@0x80000000 mem=384M@0x88000000 omapfb.mode=dvi:${dvimode} fixrtc buddy=${buddy} mpurate=${mpurate}

When I try ‘cat /proc/cmdline’, I get this;
console=ttyO2,115200n8 mpurate=800 buddy=none camera=lbcm3m1 vram=12MB omapfb.mode=dvi:1280x720MR-16@60 omapdss.def_disp=dvi root=/dev/mmcblk0p2 rw rootfstype=ext3 rootwait

It seems that the ‘dvimode’ works. However, my ‘mem=’ is not there.

Is there anybody having any clue on this?

Ilkyoung.

Hi

Have you succeeded on this topic?
I've tried several different ways of setting this mem options in my
uEnv.txt file, but none of these resulted with any differences in /
proc/cmdline.
What else do I need to force bootloader to read my "mem" options
correctly?

Thanks
suhl

ok, I did it :slight_smile:

just add the following line in your uEnv.txt file:

optargs="mem=99M@0x80000000 mem=128@0x88000000"

and yes, this is somehow different than stated in
http://www.angstrom-distribution.org/demo/beagleboard/
This works perfectly for beagleboard xM rev. C. and you can try all
the examples given by C6Run package.
I've also modified DSP_REGION_BASE_ADDR=0x9D100000 (it might work with
default values, however i didn't test it) in C6Run_0_97_03_03/
platforms/beagleboard-xM/platform.mak before building the package and
also found that in the following tutorial:
http://processors.wiki.ti.com/index.php/Getting_Started_With_C6Run_On_Beagleboard

they offer their Rules.mak file, but there is "IPC=dsplink"
deffinition missing, also there are some minnor errors to correct like
path's deffinitions.

Happy coding
suhl

Hello, Suhl,

Sorry, I didn’t check my e-mail yesterday.

Thnak you for your input on the ‘optargs’. I would be make my life much easier. :slight_smile:

As for me, I couldn’t find a way to change the value. So, I modified the u-boot source code and re-compiled it. It definitely works. :slight_smile:

Ilkyoung.

2011/6/26 suhl79 <suhlong22@gmail.com>

Hello,

Does anyone have any experience working with xenomai on the beagleboard xm?

In particular I am trying to get ethernet and spi working under xenomai.

Many thanks

David

Hi

As Xenomai seems to be another Linux kernel flavour, I think http://elinux.org/BeagleBoard/SPI would be a good start?

Ueli

Quoting David Wiebe <dwiebe2@telus.net>:

Hi

As Xenomai seems to be another Linux kernel flavour, I think http://elinux.org/BeagleBoard/SPI would be a good start?

Ueli

SPI works, the issue lies in making it work with xenomai.

David

Hi david,

I have used xenoami pacthed linux 2.6.33 on BB-xM and all xenomai api
seems OK. I used vanilla kernel, so you need to modify some part of it
in order to enable bb-xm functionalities.

Mustafa

Hi Ilkyoung,

I'm glad to hear you've already found the solution. Could You please
post in which file one can change such settings?

suhl

Hello Suhl,

I’m very sorry for my late responding. I was terribly busy for the past week. :frowning:

To change the setting, I modified the ‘U-BOOT_TOP_DIR/include/configs/omap3_beagle.h’ file.
In the file, find the CONFIG_EXTRA_ENV_SETTINGS and add '“mem=99M@0x80000000 mem=384M@0x88000000” ’ in the arguments.

That’s it!

Ilkyoung.

2011/6/28 suhl79 <suhlong22@gmail.com>