Enabling GPIO Pin 1_31 on Beaglebone Black

Hello everyone,
I have been trying to configure the GPIO Pin 1_31 on the Beaglebone Black to recieve input signals.

I have followed the following tutorials:

My specific steps were the following:

  • Enable Reset line on the Beglebone Black with the program mmc-utils(https://kernel.googlesource.com/pub/scm/linux/kernel/git/cjb/mmc-utils) executed on mmcblk0 as argument

  • Disable boot on the Beaglebone

  • Boot from SD-card

  • Changed uEnv.txt

  • Added gpio set 52

  • `Added ``mmc dev 1```

  • Added ````mmc rstn 1

  • Disabled loading of the mmc and hdmi overlays- Set Pin 33 to mode 37 with a custom device tree overlay

  • Export the Pin for input mode

Applying these steps results in the Input being high constantly even with no connected curcuit. Connecting a curcuit with an LED results in the LED glowing. Using the Pin as Output works fine. Using a pre-built device tree overlay results in the Pin constantly being low even if a current is applied. The curcuit used works with other none mmc allocated pins.

I am grateful for any kind of feedback or tips

Best Regards

Sebastian