enabling I2C1 on new ubuntu xenial image

I created a new SDcard from http://elinux.org/BeagleBoardUbuntu#Ubuntu_.28xenial.29. I am trying to activate I2C1 on this install. I had previously used ubuntu 14.04, but it looks like the method for loading overlays has changed. I can only find documentation relating to the old method. I read and followed the instructions in the new /boot/uEnv.txt, but had zero luck.

dmesg | grep bone:

[ 0.000000] Kernel command line: console=tty0 console=ttyO0,115200n8 bone_capemgr.enable_partno=BB-I2C1 root=/dev/mmcblk0p1 rootfstype=ext4 rootwait coherent_pool=1M quiet cape_universal=enable
[ 1.908347] bone_capemgr bone_capemgr: Baseboard: ‘A335BNLT,00A5,4021BBBK4800’
[ 1.908375] bone_capemgr bone_capemgr: compatible-baseboard=ti,beaglebone-black - #slots=4
[ 1.944979] bone_capemgr bone_capemgr: slot #0: No cape found
[ 1.988792] bone_capemgr bone_capemgr: slot #1: No cape found
[ 2.032780] bone_capemgr bone_capemgr: slot #2: No cape found
[ 2.076781] bone_capemgr bone_capemgr: slot #3: No cape found
[ 2.082605] bone_capemgr bone_capemgr: enabled_partno PARTNO ‘BB-I2C1’ VER ‘N/A’ PR ‘0’
[ 2.082617] bone_capemgr bone_capemgr: slot #4: override
[ 2.082631] bone_capemgr bone_capemgr: Using override eeprom data at slot 4
[ 2.082646] bone_capemgr bone_capemgr: slot #4: ‘Override Board Name,00A0,Override Manuf,BB-I2C1’
[ 2.082962] bone_capemgr bone_capemgr: initialized OK.
[ 3.098784] bone_capemgr bone_capemgr: slot #4: Failed to resolve tree
[ 3.121012] bone_capemgr bone_capemgr: loader: failed to load slot-4 BB-I2C1:00A0 (prio 0)

uEnv.txt:

#Docs: http://elinux.org/Beagleboard:U-boot_partitioning_layout_2.0

uname_r=4.4.6-ti-r15
#uuid=
#dtb=

##BeagleBone Black/Green dtb’s for v4.1.x (BeagleBone White just works…)

##BeagleBone Black: HDMI (Audio/Video) disabled:
#dtb=am335x-boneblack-emmc-overlay.dtb

##BeagleBone Black: eMMC disabled:
#dtb=am335x-boneblack-hdmi-overlay.dtb

##BeagleBone Black: HDMI Audio/eMMC disabled:
#dtb=am335x-boneblack-nhdmi-overlay.dtb

##BeagleBone Black: HDMI (Audio/Video)/eMMC disabled:
#dtb=am335x-boneblack-overlay.dtb

##BeagleBone Black: wl1835
#dtb=am335x-boneblack-wl1835mod.dtb

##BeagleBone Green: eMMC disabled
#dtb=am335x-bonegreen-overlay.dtb

cmdline=coherent_pool=1M quiet cape_universal=enable

#In the event of edid real failures, uncomment this next line:
#cmdline=coherent_pool=1M quiet cape_universal=enable video=HDMI-A-1:1024x768@60e

##Example v3.8.x
#cape_disable=capemgr.disable_partno=
#cape_enable=capemgr.enable_partno=

##Example v4.1.x
#cape_disable=bone_capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN
cape_enable=bone_capemgr.enable_partno=BB-I2C1

##enable Generic eMMC Flasher:
##make sure, these tools are installed: dosfstools rsync
#cmdline=init=/opt/scripts/tools/eMMC/init-eMMC-flasher-v3.sh

can anyone point me to current documentation on using device tree overlays with ubuntu or give me a hint as to why it would “fail to resolve tree”?

What you are trying to assess as I2C1 was renumbered to become I2C2. Currently I2C1 is reserved for the internal operation of the device, not capes.
Capes are controlled by I2C2. So you need to get a set of updated and matching overlays. You might be better off using one of the current Debian releases.
— Graham