Enabling UART1 on BeagleBone Black using Yocto

Hi !!

I am new to the yocto project. I want to enable the UART1 driver.

Yocto uses flattened device tree structure & as an example I was successfully able to enable the LED user 0.
The procedure I followed was…

  1. Go to /sys/class/gpio directory.
  2. Issued “echo 53 > export”. This created the gpio53 directory. The GPIO number of LED user0 is 53.
  3. inside the gpio directory, I executed “echo out > direction” & “echo 1 > value”.

With the execution of these simple steps I was able to enable the LED USer 0 & got it glowing in the BeagleBoneBlack.

Now on the similar lines, I would like to enable the UART1. UART0 is enabled by default in yocto, while other UARTs are not.
I echoed 46(RX) & 47(TX) GPIO numbers on the export file of the GPIO directory. I do not see the UART1 working.

Do we need to enable the UART1 is different manner? I saw internet which has lot of information for various flavors of operating system,
but I do not see any example for Yocto.

If anyone has enabled the UART1 on the linux-yocto could you please help me out.

Thanks & regards,