eqep in linux 4.4.38+ not working

Dear All,

I am using linux kernel 4.4.38+ with busybox as rfs.

I have loaded bone_eqep2b-00A0.dtbo to slots.
i.e

echo bone_eqep2b > /sys/devices/platform/bone_

capemgr/slots

Then it got loaded

[ 35.295161] bone_capemgr bone_capemgr: part_number ‘bone_eqep2b’, version ‘N/A’
[ 35.302625] bone_capemgr bone_capemgr: slot #4: override
[ 35.307977] bone_capemgr bone_capemgr: Using override eeprom data at slot 4
[ 35.314984] bone_capemgr bone_capemgr: slot #4: ‘Override Board Name,00A0,Override Manuf,bone_eqep2b’
[ 35.332763] bone_capemgr bone_capemgr: slot #4: dtbo ‘bone_eqep2b-00A0.dtbo’ loaded; overlay id #0

But in the /sys/devices/platform/ocp/48304000.epwmss/48304180.eqep i can see only

ls

driver_override of_node subsystem
modalias power uevent

There are no period, or position files to read.
It would be great if someone could help me out.

Regards,
Abhilash

My bad . It was disabled in the kernel config.

Hi Abhilash, where are the EQEP settings in the kernel config menu?
Thanks,
Justin

Hi ,
Its in device driver/misc/ ti eqep