Error compiling openembedded console-image (libpcap-1.0.0-r5)

Hi,

After updating from the openembedded git, I am getting the following
error while executing "bitbake console-image"

Hi Everyone,

Can someone please try to help me with the above error ?
I have checked that the bluetooth header files listed in the error
log, are there...

I have the same problem with you :9)

maybe we don’t need the bluetooth function on BB.

Thanks for the response... Looks like no one else has faced this problem
given the response to this since this problem was posted last week. I am
wondering if there is there a way to fix this or exclude this package from
compilation. My knowledge on Bitbake is still limited, but i'll give this a
try.

-Nitin

OK, So finally I had to remove this package from the task list to get the build going. I tried to fix the include paths in the Makefile but that didn’t work. Even tried to include the files from their absolute paths in the c file pcap-bt-linux.c which fixed the above mentioned errors but started popping other errors. I believe that this is something wrong going on my system (and maybe Favor’s too) so to move further, I removed this task and the build went OK.

I just hope that the rootfs works fine with 2.6.28-r12 uImage which I compiler earlier.

Thanks
-Nitin