Error in for installing ubuntu lucid on beagleboard


I followed instructions on this page:

While running: sudo ./ --mmc /dev/sdX --uboot beagle --
swap_file 50, I get an error as:

HI Gopal,

Once the above happens, there's not much my script can do.. I'd make
sure you have all your os updates and reboot the os.. Give the script
a couple more runs, otherwise your going to have to do everything

Starting about here and working down:

One thing not mentioned there is "--use-default-user" which just
requires you to remove "/var/lib/oem-config/run"


i don't know if this is a problem for you but i know
where that error can come from; usually it means you had a partition
mounted and then tried to change the same partition table.

did the instructions warn you about that?

Well, the first thing the script does, is umount all devices on
/dev/sdXy, but i wonder if ubuntu auto-mounted the partition shortly
after running mkfs.ext4 on it.. as the next thing the script does is
then remount the partition.. It would be worth a quick check..


Finally it worked. It was probably only a reboot required for my host
machine. Thanks Robert..
Now I am searching for a driver for USB-ethernet device so I can see
the real desktop on my host itself using VNC.