Error Message after running command " MACHINE=beagleboard ./oebb.sh bitbake console-image "

Hello All,
I am Following tutorial Getting Started With C6Run On Beagleboard. I am done with OpenEmbedded and Angstrom Setup step successfully. But I didn’t get any luck in step Building Base Image for Beagleboard.
When I did run coomand " MACHINE=beagleboard ./oebb.sh bitbake console-image ". As it takes a long time, I kept it running . When I came back, I saw following error message. I try to run same command but ended up with same error. I searched for error message.But I didn’t get answer. I have detailed error message. Can anybody have same problem ? Please give me right pointer, if I am missing something.

make: *** [u-boot] Error 1

ERROR: oe_runmake failed
NOTE: package u-boot-2011.12-r5: task do_compile: Failed
ERROR: Task 139 (/home/metrans/setup-scripts/sources/meta-ti/recipes-bsp/u-boot/u-boot_2011.12.bb, do_compile) failed with exit code ‘1’
Waiting for 1 active tasks to finish:
0: task-base-1.0-r73 do_configure (pid 29761)
NOTE: package task-base-1.0-r73: task do_configure: Started
NOTE: package task-base-1.0-r73: task do_configure: Succeeded
NOTE: Tasks Summary: Attempted 3252 tasks of which 3244 didn’t need to be rerun and 1 failed.

Summary: 1 task failed:
/home/metrans/setup-scripts/sources/meta-ti/recipes-bsp/u-boot/u-boot_2011.12.bb, do_compile
Summary: There was 1 ERROR message shown, returning a non-zero exit code.

Error Message (45.4 KB)

Hello All,
    I am Following tutorial Getting Started With C6Run On Beagleboard. I am done withOpenEmbedded and Angstrom Setup step successfully. But I didn't get any luck in stepBuilding
Base Image for Beagleboard.
When I did run coomand " MACHINE=beagleboard ./oebb.sh bitbake console-image ". As it takes a long time, I kept it running . When I came back, I saw following error message. I try
to run same command but ended up with same error. I searched for error message.But I didn't get answer. I have detailed error message. Can anybody have same problem ? Please give
me right pointer, if I am missing something.

make: *** [u-boot] Error 1
> ERROR: oe_runmake failed
NOTE: package u-boot-2011.12-r5: task do_compile: Failed
ERROR: Task 139 (/home/metrans/setup-scripts/sources/meta-ti/recipes-bsp/u-boot/u-boot_2011.12.bb <http://u-boot_2011.12.bb>, do_compile) failed with exit code '1'
Waiting for 1 active tasks to finish:
0: task-base-1.0-r73 do_configure (pid 29761)
NOTE: package task-base-1.0-r73: task do_configure: Started
NOTE: package task-base-1.0-r73: task do_configure: Succeeded
NOTE: Tasks Summary: Attempted 3252 tasks of which 3244 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
   /home/metrans/setup-scripts/sources/meta-ti/recipes-bsp/u-boot/u-boot_2011.12.bb <http://u-boot_2011.12.bb>, do_compile
Summary: There was 1 ERROR message shown, returning a non-zero exit code.

There is something seriously wrong with your system - there are many
errors like this in that log:
    > /bin/sh: Syntax error: Bad fd number

What's your host system? Ubuntu perhaps? If so, try this:
   % sudo dpkg-reconfigure dash

Hi Thank for reply.
I did run sudo dpkg-reconfigure dash and rerun" MACHINE=beagleboard ./oebb.sh bitbake console-image ". It still gives same errors. I am using ubuntu 10.10. What Can you do next ?

Hi Thank for reply.
  I did run sudo dpkg-reconfigure dash and rerun" MACHINE=beagleboard ./oebb.sh bitbake console-image ". It still gives same errors. I am using ubuntu 10.10. What Can you do next ?

Try removing the build directory to force a 100% clean restart. If this error persists,
it may be something wrong with your host computer - the error that's you're seeing is very
serious and should never happen.

n.b. don't top-post :frowning:

Hi Thank for reply.
I did run sudo dpkg-reconfigure dash and rerun" MACHINE=beagleboard ./oebb.sh bitbake console-image ". It still gives same errors. I am using ubuntu 10.10. What Can you do next ?

Try removing the build directory to force a 100% clean restart. If this error persists,
it may be something wrong with your host computer - the error that’s you’re seeing is very
serious and should never happen.

n.b. don’t top-post :frowning:

Hello All,
I am Following tutorial Getting Started With C6Run On Beagleboard. I am done withOpenEmbedded and Angstrom Setup step successfully. But I didn’t get any luck in
stepBuilding

Base Image for Beagleboard.
When I did run coomand " MACHINE=beagleboard ./oebb.sh bitbake console-image ". As it takes a long time, I kept it running . When I came back, I saw following error
message. I try
to run same command but ended up with same error. I searched for error message.But I didn’t get answer. I have detailed error message. Can anybody have same problem ?
Please give
me right pointer, if I am missing something.

make: *** [u-boot] Error 1

ERROR: oe_runmake failed
NOTE: package u-boot-2011.12-r5: task do_compile: Failed

ERROR: Task 139 (/home/metrans/setup-scripts/__sources/meta-ti/recipes-bsp/u-__boot/u-boot_2011.12.bb <http://u-boot_2011.12.bb> <http://u-boot_2011.12.bb>, do_compile)

failed with exit code ‘1’

Waiting for 1 active tasks to finish:
0: task-base-1.0-r73 do_configure (pid 29761)
NOTE: package task-base-1.0-r73: task do_configure: Started
NOTE: package task-base-1.0-r73: task do_configure: Succeeded
NOTE: Tasks Summary: Attempted 3252 tasks of which 3244 didn’t need to be rerun and 1 failed.

Summary: 1 task failed:

/home/metrans/setup-scripts/__sources/meta-ti/recipes-bsp/u-__boot/u-boot_2011.12.bb <http://u-boot_2011.12.bb> <http://u-boot_2011.12.bb>, do_compile

Summary: There was 1 ERROR message shown, returning a non-zero exit code.

There is something seriously wrong with your system - there are many
errors like this in that log:

/bin/sh: Syntax error: Bad fd number

What’s your host system? Ubuntu perhaps? If so, try this:
% sudo dpkg-reconfigure dash

Gary,
Thanks for your help. I did some search for /bin/sh: Syntax error. I got one good post, I tried that one , it works perfectly. I would like to post that link here for people who may face same problem like me.

http://www.pioverpi.net/2010/01/29/shell-commands-in-python-sh-errors/