Error Running "make" in BeagleBoard-DeviceTrees

Hey there,

I have been trying to get UART to work on the BeagleBone AI-64 following the steps that were outlined in this post: Enable UART 1 on BB AI-64

I’ve successfully cloned the repo but have run into an issue trying to run make, which returns a scripts/basic/fixdep: not found.

Any advice on how to proceed from here?

I’ve successfully run make and have managed to load the UART1 overlay, which appears when running sudo beagle-version | grep UBOOT:

Likewise, UART1 appears in /dev/bone/uart/ and is supposedly mapped to ttyS4:

However, I’m not getting anything out of pin P8.18 (UART1_TXD) using echo "test" > /dev/ttyS4 when hooked up to a logic analyzer. Any clue why this might be?

1 Like

sudo make install_arm64 may do it.

I know it is a bit different on the BBAI-64 compared to the BBB.

After running make, then proceed w/ the above command.


P.S. There are also files to look over. One in particular is the /extlinux/extlinux.conf file.

I think that file is located in either the /boot/firmware/ directory or something close in /boot/.

I also see you are using the am5729 which is on the BBAI and not the BBAI-64. This may be somewhat of a confusion so far. Um, so look to and then look over their BeagleBoard-DeviceTrees for answers. It may help.

Yeah I’ve successfully run make install_arm64 and have gotten the UART1 overlay to load. I’ve also edited my extlinux.conf to include fdtoverlays /overlays/BONE-UART1.dtbo, but I still haven’t had any luck with getting an actual output out of the UART pins.

1 Like

@Eddie_Liao ,

Are you sure you are using the correct one from or are you still using the one from I am not sure about the differences right now…

There is a 5.10.x-ti and a 5.10.x-ti-unified, I think. Let me go and check.

Yeppers. So, there are two, separate DTS/overlays repos. and two, separate DTS/overlays kernel choosings.

I think you may have to pick and choose and then debug depending on what you choose.


I can test over here too. I see they have a Fan DTS file now in 5.10.x-ti-unified but there is also a 5.10.x-ti-arm64.


P.S. Give me some time. I may be able to pull straws out of my hat and pick the right one! Bear w/ me.


Also…the repo. states they tested w/ sudo.

Also @Eddie_Liao ,

I am not 100% sure but you may have to reboot for it to take place.


P.S. I am plugged in now and I will test shortly. Also, the UART in question that was used is even on the minimal image provided by or So, I think you may not need the DTS from github but I could be wrong. Still testing!


Sorry. This is going to take longer than expected. I put a RT-kernel on this machine. I will need to write a new image and boot from it. Wish me luck!

If you have any updates on booting into ttyS4 from UART1, go for it!

I’m using the 5.10.x-ti-unified from, although from what I can tell the repo hosted on GitHub is a straight mirror of the one on From what I can tell UBOOT is loading the UART1 overlay, but I still haven’t had any luck getting an output.

Let me know if you’ve made any progress.


It’s working! I looked into k3-j721e-beagleboneai64-bone-buses.dtsi and it turns out that UART1 is physically mapped to UART2 as seen below:

bone_uart_1: &main_uart2 {
	/* tested with sudo agetty 115200 ttyS4 */
	pinctrl-names = "default";
	pinctrl-0 = <
		&P9_24_uart_pin /* uart2_txd */
		&P9_26_uart_pin /* uart2_rxd */
	symlink = "bone/uart/1";
	status = "disabled";

Plugging my logic analyzer into P9_24 (uart2_txd) returns a proper output! Not sure if this is documented anywhere (or the purpose behind setting UART1 to the pins for UART2), but good to know that things are working now.

Solution to Original Post

Running make all_arm64 worked on the BBAI64 instead of just make; from there, sudo make install worked as normal. For future reference, UART1 utilizes the pins for UART2 (P9_24 and P9_26 for TX and RX respectively).

1 Like