Error updating to the Angstrom Distribution 2013-06-20; board broken!!

Hi everybody,

I have just download the Angstrom Distribution (BeagleBone Black) 2013-06-20 and follow all the instructions to update my BBB using a Mac, and apparently everything went well, but when I connected the board again to the computer, there was no “beaglebone” folder in the desktop with the information and drivers, and I couldn’t connect again with the board through the 192.168.7.2 IP and there is no more Cloud9 development IDE in 3000 port. The card even stop loading Linux when connected to the TV and it gets really hot.

What can I do? Is there any way to restore the board as it came from factory? Have I used the correct image to flash the memory?

Please, help me!

Thanks

http://circuitco.com/support/BeagleBoneBlack, the link on the white card that came in the box, has instructions on how to put an older version of the SW back onto the board. Same process as the 6_20 image, which is currently the image we use on all boards shipped from the factory.

Gerald

I also could not get that distribution to work on my BBB. I installed BBB-eMMC-flasher-2013.05.08.img and it worked again. Something is wrong with BBB-eMMC-flasher-2013.06.20.img. You probably did not break the board.

It works fine. We ship it on every board that goes out there door. If you do it right and don’t take shortcuts, it should work. Make sure no Ethernet is attached and that you power from a DC power supply.

Gerald

I think you’ll need to get an RMA for the board because if BBB-eMMC-flasher-2013.06.20.img doesn’t work on it then it must be defective.That’s what I’m going to do. It’s not 90 days yet so I have some time.

At first I thought I was doing something wrong in the flashing procedure. I did the flash to BBB-eMMC-flasher-2013.06.20.img.and at the end (45 minutes or so) all four LEDs were on, indicating success. No Ethernet cable plugged in, no USB or HDMI cable either. A very stable, high-current, 5V supply plugged into the barrel jack, not powered from the Mini-USB. But the board would not boot after flashing BBB-eMMC-flasher-2013.06.20.img. I tried it several times with multiple downloads from the Circuitco site and just could not get the board to boot following the flashing of the 2013.06.20 image. When I flashed BBB-eMMC-flasher-2013.05.08.img the board worked fine so clearly I am doing the flashing properly in terms of holding down S2 while plugging in power and releasing it when the user LEDs were all lit up (one site says you can release the button after the first LED lights, one says to wait until all four user LEDs light up, so I tried it both ways, but no luck). It’s very time consuming to flash images.

Also, If I try to run from the MicroSD card with the non-eMMC images the board works fine with Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.12-beaglebone-2013.05.28.img but not with Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.12-beaglebone-2013.06.20.img. Clearly there’s some issue with the board I have and the 06.20 image. I thought that it was a problem with 06.20 image but Gerald says that it’s fine.

Finally, after a few hours, a dozen of tries and a new 8GB uSD broken (no one of my computers recognize it, even under Linux with GParted) I managed to install again the operative system (last version).Don’t ask me how, but it finally works. It is real weird.I tried writing the uSD using Mac and Windows and flashing the BBB following the instructions without results, and it suddenly works. Almost an hour flashing and then the 4 status led stop blinking and stay turned on. The board is working now and apparently everything is OK. I have enough time until the 90 days test period and I will observe it, but for the moment it works :slight_smile:

OK. thanks for pointing out the image in bold. I might have missed it otherwise.

I will be looking for the RMA to come through.

Gerald

Glad you got it working!

Gerald

Thanks :slight_smile:

But I’m not going to update it again until 2020.

Oh no! By then then Kernel will be up to version 179.8!

Gerald

Thanks. I downloaded the BBB-eMMC-flasher-2013.06.20.img again today, and tried again, but no dice.I also tried the Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.12-beaglebone-2013.06.06.img from the Micro-SD slot and it didn’t work. But Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.12-beaglebone-2013.05.28.img worked just fine. Very strange. I requested an RMA and I’m waiting for a return e-mail.

I looked at the contents of uenv.txt after I flashed BBB-eMMC-flasher-2013.06.20.img and all that’s in there is optargs=quiet drm.debug=7. Is this correct?

Yes.

Gerald

I am wondering if there’s some issue with HDMI on the newer releases. With 06.20 the board appears to have booted. There is HDMI video at the very beginning of the boot process then the screen goes blank. First I see the dog and Beaglebone at the top of the screen, then there’s a text screen with an opportunity to login for a few seconds, then the screen goes blank and says “no signal.” With 05.08 and 05.28 (from the MicroSD card) the video works properly. I am using the Motorola Bionic Lapdock. Besides working fine with 05.08 and 05.28 it works fine with the Raspberry Pi. The resolution of the Lapdock screen is 1366 x 768.

Do you have a network cable plugged in? If so, try plugging in a
keyboard or a mouse, or "kick" the screen via the command line:

echo 0 > /sys/class/graphics/fb0/blank

If you don't have any user input but the network is connected, the clock
gets set via NTP at boot, and since there is no RTC on the 'Bone the
system thinks it's been over 13 years since it got the last user input
and it blanks the display.

There are some details on the screen blanking towards the bottom of my
post on setting the HDMI resolution:

http://bb-lcnc.blogspot.com/2013/06/force-beaglebone-black-hdmi-resolution.html

Apparently, the problem is not with the board, but with the 06.20 image which broke some of the HDMI functionality. I have been using a Motorola Lapdock which works fine with 0508 (and with the Raspberry Pi), but does not work with 0620. Maybe the next image will fix the HDMI support for the Lapdock, which is a very popular device to use with the Beaglebone and with the Raspberry Pi.

I think that there should be a note somewhere on the Wiki or somewhere on the specifications page that explains that to use a Motorola Lapdock you must use one of the older Angstrom releases.