Error while inserting the camera driver for mt9t112 for LI-LBCM3M1 camera module from leapord


I am new to BeagleBoard-xM rev C.

I tried doing insmod in command line as :

root@beagleboard:/lib/modules/3.2.18-yocto-standard/kernel/drivers/media/video# ls
gspca mt9v011.ko v4l2-int-device.ko
ir-kbd-i2c.ko mt9v022.ko videobuf-core.ko
mt9m001.ko soc_camera.ko videobuf2-core.ko
mt9m111.ko soc_camera_platform.ko videodev.ko
mt9t031.ko soc_mediabus.ko
mt9t112.ko v4l2-common.ko
root@beagleboard:/lib/modules/3.2.18-yocto-standard/kernel/drivers/media/video# insmod mt9t112.ko
Error: could not insert module mt9t112.ko: Unknown symbol in module

But i got error as could not insert module mt9t112.ko: Unknown symbol in module.

I don’t know why i am not able to insert the module, i tried creating my own hello world kernel module and can insert that but why i cannot able to insert the driver module for 3megapixel camera (driver name mt9t112 & camera module =lbcm3m1) i have set the camera variable to lbcm3m1.
Please anyone guide me where to find the solution.