Errors faced while installing Eclipse

I did a

apt-get install eclipse

It started Getting the files, selecting and unpacking etc…

Just when I thought everything was going on perfectly fine. I get the following message:

Setting up openjdk-6-jre-lib (6b32-1.13.4-1~deb7u1) …
Setting up libosgi-compendium-java (4.3.0-1) …
Setting up libfelix-gogo-runtime-java (0.10.0-2) …
Setting up libfelix-gogo-command-java (0.12.0-2) …
Setting up libfelix-gogo-shell-java (0.10.0-2) …
Setting up eclipse-rcp (3.8.0~rc4-1) …
Setting up libfelix-shell-java (1.4.2-3) …
Setting up libfelix-utils-java (1.1.0-3) …
Processing triggers for ca-certificates …
Updating certificates in /etc/ssl/certs… 0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d…
done.
done.
Errors were encountered while processing:
binfmt-support
jarwrapper
sat4j
eclipse-platform
eclipse-jdt
eclipse-pde
eclipse
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any ideas on how I can ensure that my Java/jdk/jre environment is setup correct?

Thanks is advance!!