Externally powered usb hub


I connected an USB hub (having external power socket plugged in) to Beaglebone Black. I want to capture images from a webcam connected to this usb hub. Also some other usb devices (printer, mouse) are connected.

I am trying to capture images from command line by using ‘fswebcam’ application of Debian for Beaglebone. I am loading a configuration file as an argument to ‘fswebcam’ which adjusts white balance, exposure, etc.

At every time I run this command, I get different jpg pictures. Configuration that i supply does not work, it looks like every photo has a different configuration.

I also tried ‘uvcdyncntrl’ to set camera parameters then taking photos. It also did not give reliable results.

Are these software not stable of is it about my camera (Logitech c920)?

Thank you,


Could you post a couple of sample images?

I getting very flaky behavior with the Beaglebone and BeagleboneBlack with and without a USB hub. I’m using HP2200 and HP3110 webcams and have tried
all these kernels:

uname -a
Linux beaglebone 4.1.5-ti-r10 #1 SMP PREEMPT Thu Aug 13 20:24:29 UTC 2015 armv7l GNU/Linux
Linux beaglebone 4.2.0-bone2 #1 Mon Aug 31 09:45:24 UTC 2015 armv7l GNU/Linux
Linux beaglebone 3.8.13-bone74 #1 SMP Wed Aug 12 00:12:46 UTC 2015 armv7l GNU/Linux

Both cameras work fine on my Raspberry Pi2 using fswebcam or openCV.

At this point my solution appears to be buy another Pi2 for this project. There was a bunch of updates recently, I’m applying them now and will report back if they solve the problem