Extracting IMG for Beaglebone on Windows


I’m wanting to download and extract the latest version of the beaglebone image, and use the Win32 disk imager util to update my SD card…

I’ve downloaded this file:


However, I’ve tried various methods to extract the image file and it doesn’t work… I used 7-Zip which fails telling me the image is corrupt, and I’ve also downloaded several free utils to unzip .xz files which extract a file of 2MB!

I’ve also tried downloading the image several times, and always the same issue…

Is anyone else having the same problem?


Start here. http://circuitco.com/support/index.php?title=BeagleBone#Image_Files

Get the process down. Then switch to this image and see if it still does not work or use one of the images listed at the above location…


The file at that URL appears to be valid.

I was able to extract the .img file using 7-zip (version 9.2 on Win 7 x64).

The downloaded .xz file should be 148,538,884 bytes. The extracted .img file is 3,652,024,320 bytes.

To be sure that you have a valid download, you can run md5sum (from http://www.pc-tools.net/win32/md5sums/) on the .xz file and compare the result to what is listed on the page (at http://www.angstrom-distribution.org/demo/beaglebone/md5sums)


Cheers, the file size is perfect… but I’ve downloaded a further 6 times and everytime I get a different checksum! Bizzare…

not sure what’s going on here to be honest, wonder if my virusscan is doing something to the file as I download it…



I’ve managed to download the image from http://circuitco.com/support/index.php?title=BeagleBone#Image_Files without any issue, extracted using 7-Zip and then transferred it to my SD card (after reformatting it using the HP Format tool). The card boots fine and works great

However, no matter what I try, I cannot download and extract the latest image from http://www.angstrom-distribution.org/demo/beaglebone/Angstrom-Cloud9-IDE-eglibc-ipk-v2012.02-core-beaglebone-2012.02.14.img.xz

I have disabled my Antivirus and tried many times, I’ve also used the MD5sum as suggested, but each time the checksum is different (and not the one suggested on the site). When I try to extract with 7-Zip, it extracts a maximum of 20MB and then fails telling me the file is corrupt. Most of the time it only extracts 2 - 4 MB before giving an error…

I am 99.9% certain I am doing everything correctly, it’s asthough there is a problem with this image file or the hosted server I’m attempting to download from

Any help, hints & tips greatly appreciated…


Does the computer your are doing the download to, connect to the
internet by a wireless link at some point?

If so, try doing the download with a wired connection (either on that
computer, or from another).

(I once had a similar problem. I downloaded a 1-gig file about six
different times, over a wireless link. Each time there were several
bits (out of the ~8 billion!) that were wrong, which of course showed
up in the hash/checksum. And there were *no* TCP errors reported.
The first time I downloaded it with a wired connection, it worked
properly. A friend of mine suggested this to me, he said that some
cheap wireless routers can do this (make bit errors, and generate TCP
checksums from the erroroneous data)).

Cheers, certainly worth a try… odd though how it managed to download the image from CircuitCo.com without any issues, and I’ve never had problems downloading huge files in the past (such as Ubuntu etc). I wouldn’t mind, it’s not a cheap wireless router either!

I’ll report my findings…


Nope that didn’t work either… in fact, only extracted 300KB before failing this time

Did you try the http://beagleboard.org/angstrom mirrors?

Cheers Jason, I did try looking here… however, the latest image doesn’t appear to be there…


I finally managed to get this image downloaded, I upgraded the firmware on my router… Very odd that I have never had issues downloading anything in the past and I’ve downloaded many gigabytes!

My next question… I now want to download the kernel source files for this image version… Where is the best place to obtain these? previously I’ve downloaded and compiled this version: https://github.com/koenkooi/linux/tree/linux-ti33x-psp-3.1-r2l+gitr1d84d8853fa30cf3db2571a5aec572accca4e29d

This works fine, and I managed to get the old image updated with the above kernel files, compiled directly on the BeagleBone… However, I don’t want to use these kernel source files but I won’t want to end up with reverting the fixes / patches and updates applied in the latest version of the image

Sorry again for the beginner questions, I’m no linux expert, and just learning my way around…

Thanks again for everyone’s assistance so far!