Fail to flash eMMC of new BeagleBone Blacks with older Debian Image

Hi folks,

So I have an old BeagleBone Black Rev C (about 2 years old) with his original Image on eMMC:

  • Debian Image 2015-11-12 (7.9 original, 7.11 after after #sudo apt-get update)
  • Kernel 3.8.13-bone79

I use this one to copy his content his eMMC content to a SDcard flasher using this script:


I clone other BBB’s about 1 year ago with this SDcard flasher, that came already with a original Debian Image:

  • Debian Image 2016-01-24 (8.3)
  • Kernel 4.1.15-tu-rt-r43

Everything has ok, i was able to clone every BBB.

About 1 week ago, I bought newer BBB that came with the same Debian Image (2016-01-24) and with the same Kernel (4.1.15-tu-rt-r43).
The problem was, I can’t flash the eMMC of this newest BBB’s, with my original SDcard flasher, the LED 3(USR 2) just stays steady ON forever.
After reading some similar threads, it was something about the newer BBB have with different eMMC, and I run #git pull in /opt/scripts/tools/eMMC, after this I run again ./

After several fails I did other 3 different test:

1 - After reading some similar threads, it got to the conclusion that is something about the newer BBB have with different eMMC, and I run #git pull in /opt/scripts/tools/eMMC, after this I run again ./ to another SDCard, the result was a different (a bit inconclusive), but failed anyway, this time the LED 1 (USR 0) just start to blink twice (heartbeat) and the others leds stayed off forever…

  • eMMC of BBBs bought 1 and 2 years ago (with different original Debian Images) - EMMC04G-S100
  • eMMC of the newest BBB’s - EMMC04G-M627

2 - The second test was, writing 2 different original Debian Images from

  • Debian 9.3 2018-01-28 4GB SD IoT
  • Debian 7.9 2015-11-12 4GB SD LXDE
    Both images run from SDcard, after this I uncomment the line #cmdline=init=/opt/scripts/tools/eMMC/ to flash the eMMC, and only the Debian 9.3 was succesfully written to eMMC, the Debian 7.9 fails (USR 2 steady on forever).

3 - The third test was using this method:, after succesfully extract the content of my oldest BBB to the SDcard, I used it in a newer on, and it runs, but after I uncomment the line #cmdline=init=/opt/scripts/tools/eMMC/, the same happens (USR 2 steady forever)

Any help, would be nice

eMMC 5.1 support was added with 3.8.13-bone80 back on Jun 15, 2016...

Upgrade your 3.8.13-bone79 kernel to 3.8.13-bone80

see for example:

to build on your own..