Failed flashing of debian

I am brand new to Linux, so hopefully I can give enough info to get help with my problem.

I recently received my bbb, and immediately got to flashing. I've had success getting Ubuntu (12.04,13.04), android, and reflashing angstrom.

Today I tried to flash debian wheezy. All went normal until trying to install gnome desktop. I get a message in terminal that says "E:read 989 read but none left" or something to that effect, and it appears to me that installation is not happening.

Is this normal? All the other distros I flashed showed me they were making progress, ie;getting, setting up indications on screen.

So, I tried flashing a different image, but my bbb thinks it's still in reboot phase of installation from after I repartitioned the microsd, before resize2fs command takes place. So, I can't flash something different, and I can't flash what I'd started with. What do I do?

I'm sure I've left out pertinent information, so please, help me help you help me. Tell me what you need to know to help me. Thank you in advance

Reflash with:

Making sure to HOLD down the button next to the microSD card BEFORE
you power the board..

Recovery/reflash should take 6-7 minutes...


Tried that, but still getting
“E: Read, still have 989 to read but none left” prompt when you’d expect the downloading process to take place.

I’ve followed circuitco’s tutorial to the t, but I’m still having this issue.

Tried that, but still getting
"E: Read, still have 989 to read but none left" prompt when you'd expect the
downloading process to take place.

Well other then your email message google nor I have ever seen that error..

I've followed circuitco's tutorial to the t, but I'm still having this

Okay I tried by recommending something different, so Good Luck!


I’ve neglected a piece of information. I’m trying to install the full desktops.

Now, as I said before, I’ve successfully managed to flash other distros, so I don’t believe I’ve made any errors in the actual installation process, and I’ve followed tutorials, where needed

I’m kind of stuck right now, as I can’t install/flash anything, as my bbb is still not allowing me to boot off the sd for whatever reason. my only guess as to why that is, is because theres a script or something running from my first attempt at this, and my bbb hasn’t finished some piece of it?

I dunno, thats why I’m here

If it's not booting of the microSD card, it can be...

1: Wrongly formatted microSD card..
2: "Broken" uEnv.txt, aka the eMMC which boots first is expecting
something else in the microSD


Remove power plug & otg usb, place microSD in slot, push and hold boot
button, plug in power, wait for all 4 led's to light, let off boot

Or grab a usb-serial adapter and find out what the bootloader is
actually doing, otherwise it's just guess work..


Appreciate the help very much. I've managed to get past the problem by just letting it run it's course. The message eventually ended, and I was back at the command line. Currently in the process of trying to get ubuntu back on it. Again, many thanks