failure of all USB devices when running uImage-2.6.29-r37-beagleboard.bin on rev C


I'm guessing that this is the very same issue as "[beagleboard] mouse is not
working" from Sanjeev Kumar Verma yesterday. The failure with the new code
is simply that nothing on my powered USB hub plugged into the OTG port
(specifically my USB keyboard, mouse, and Trendnet network dongle) works

I'm booting from the SD card and have partitioned it according to the
instructions. I have labeled the FAT partition "boot" and the ext3
partition "rootfs".

I have taken the latest files from and I've installed
them like so:

cp MLO /media/boot/
cp u-boot.bin /media/boot/
cp uImage-2.6.29-r37-beagleboard.bin /media/boot/uImage

tar xvf
d.rootfs.tar.bz2 -C /media/rootfs
tar xvf modules-2.6.29-r37-beagleboard.tgz -C /media/rootfs

The full boot log is given below. The system appears healthy except the
mouse, keyboard and network don't work.

One other piece of information:

If I change nothing on the SD card *except* moving back to the old kernel
installed like so:

cp uImage-2.6.28-r17-beagleboard.bin /media/boot/uImage

then the keyboard and mouse DO work but the network still does not.


How much current can your hub's power supply supply?
I find I am on the hairy edge at most times with a 500 mA motorola
cell phone charger.
The "recommended" power supply provides 2 amps.

The power explanation is unlikely in this case as those same USB
devices all work flawlessly with the prior version of software but not
at all with the latest version. As I switch between the software
versions the devices work or don't work as a very dependable function
of *just* the version of SW I'm running.

regardless its still good info to know for trouble shooting purposes.
another related anomaly is the ability to boot via OTG port plug in
powered hub to usb host and then unplug OTG port and watch it still

I do know that when I have sufficient power I do NOT have mouse and
keyboard problems.
and when I dont, i do...

The specs on the hub power supply claim: "5V 2A". Two Amps really
should be sufficient and indeed it certainly is as long as I'm running
working software.

There is the issue of my post but also look at:

"EHCI not work at custom kernel" and
"mouse is not working"

It appears likely that some driver problem has found its way into the
latest code.

I had a similar issues a few days ago with a C3 beagle board. It
seemed to be bootloader related. If I started u-boot from nand (U-Boot
2009.01-dirty (Feb 19 2009 - 12:22:31)), then I had the following
- couldn't get host mode working on the OTG port (no HUB, mouse, keyboard)
- normal host drops USB connections with EMI error after a 2-3 minutes
of uptime.

If I started u-boot from SD (U-Boot 2009.01-00013-g52eddcd (Feb 03
2009 - 22:25:11)) then everything works as expected, no reliability

You should give it a try with an older bootloader that doesn't do any USB stuff.


Not working:
U-Boot 2009.01-dirty (Feb 19 2009 - 12:22:31)
I2C: ready
OMAP3530-GP rev 2, CPU-OPP2 L3-165MHz
OMAP3 Beagle board + LPDDR/NAND
DRAM: 256 MB
NAND: 256 MiB
MUSB: using high speed
In: serial
Out: serial
Err: serial
Board revision C
Serial #3342000300000000040323090d002016

U-Boot 2009.01-00013-g52eddcd (Feb 03 2009 - 22:25:11)
OMAP3530-GP rev 2, CPU-OPP2 L3-165MHz
OMAP3 Beagle board + LPDDR/NAND
DRAM: 256 MB
NAND: 256 MiB
Using default environment
In: serial
Out: serial
Err: serial
Board revision C
Serial #3342000300000000040323090d002016

Hi Gyorgy-

I tried reverting to an older u-boot image I had (not the exact
version that worked for you) but it makes no difference; the failure/
success appears to be a function of the kernel version rather than the
u-boot version. But perhaps the older kernels will upon boot clean up
any USB mess that might have been left by the u-boot whereas the newer
kernels no longer do this? In any case I would like to do the
experiment of using the exact version of u-boot that worked for you.
Could you email this to me?