fdtoverlays not working in extlinux.conf

I’ve added a custom overlay to /boot/firmware/overlays and updated /boot/firmware/extlinux/extlinux.conf with the contents

fdtoverlays /overlays/BBAI64-MYOVERLAY-01-00A1.dtbo

I am getting the error

Ignoring unknown command:     fdtoverlays

I imagine updating U-Boot might fix the issue. Is there a path you could advise in applying custom overlays in Debian?

Yeap, you’ll need to update u-boot, this was a feature we enabled after the original production image went to manufacturing…

For an old factory install:

sudo apt update
sudo apt install --only-upgrade bb-j721e-evm-firmware generic-sys-mods
sudo apt upgrade

Then update u-boot via:

sudo /opt/u-boot/bb-u-boot-beagleboneai64/install-emmc.sh
sudo /opt/u-boot/bb-u-boot-beagleboneai64/install-microsd.sh
sudo reboot

/boot/firmware/overlays/

Is the correct location for these files, U-Boot’s extlinux, only scans the first FAT partition, (which maps to /boot/firmware (where the fat partition is mounted in linux))…

Regards,