freaking out with EDIMAX EW-7811UN on BBB with Angstrom

Hi all,

I’m trying to get EDIMAX EW-7811UN to work on my fresh BBB with Angstrom with no success. I choose this adapter because BBB-Wiki says it would works on Angstrom.

I’ve read already all topics on this group about EDIMAX+BBB and pick this tutorial I’ve use to compile the driver on BBB by myself: How to install a rtl8192cu… I guess I overlooked something trivial and hope somebody may kick me to the right direction.

My setup is: ethernet, power supply, edimax dongle. No usb-keyboard, no HDMI. The boards stands on a book, so the usb dongle looks over. An usb cable to extend the distance to BBB I’ve try as well.

dmesg is too big to post here so I’ve attachted a file, one thing only I see could be the issue:

[ 16.193417] systemd-udevd[93]: worker [109] terminated by signal 11 (Segmentation fault) [ 16.281490] gs_open: ttyGS0 (dd5d3c00,dd58c5c0) [ 16.285720] gs_close: ttyGS0 (dd5d3c00,dd58c5c0) ... [ 16.285742] gs_close: ttyGS0 (dd5d3c00,dd58c5c0) done! [ 16.286023] gs_open: ttyGS0 (dd5d3c00,dd40b540) [ 16.308695] systemd-udevd[93]: worker [109] failed while handling '/devices/ocp.3/47400000.usb/musb-hdrc.0.auto/gadget/net/usb0' [ 16.407298] survey done event(4)

otherwise I see in dmesg no trys to connect, to auth or something else …

`
root@beaglebone:~# ifup wlan0
Successfully initialized wpa_supplicant
ioctl[SIOCSIWAP]: Operation not permitted
udhcpc (v1.20.2) started
Sending discover…
Sending discover…
Sending discover…
No lease, failing

`

root@beaglebone:~# **iwlist wlan0 scanning** wlan0 Scan completed : Cell 01 - Address: 50:7E:5D:4F:20:EE ESSID:"WLAN-4F2046" Protocol:IEEE 802.11bgn Mode:Master Frequency:2.437 GHz (Channel 6) Encryption key:on Bit Rates:144 Mb/s Extra:rsn_ie=30140100000fac040100000fac040100000fac020000 IE: IEEE 802.11i/WPA2 Version 1 Group Cipher : CCMP Pairwise Ciphers (1) : CCMP Authentication Suites (1) : PSK IE: Unknown: DD910050F204104A00011010440001021041000100103B0001031047001000000000000000030000507E5D4F20EE1021000B436F72706F726174696F6E10230009564756383533394A5710240008312E32382E3030301042000A4A3233373134303237361054000800060050F204000110110014576972656C65737320526F757465722857464129100800020084103C000103 Quality=100/100 Signal level=84/100

`
root@beaglebone:~# ifconfig
eth0 Link encap:Ethernet HWaddr 90:59:AF:5D:BD:E3
inet addr:192.168.2.101 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::9259:afff:fe5d:bde3/64 Scope:Link
inet6 addr: 2003:4c:6d26:ff01:9259:afff:fe5d:bde3/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:464 errors:0 dropped:1 overruns:0 frame:0
TX packets:222 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:78198 (76.3 KiB) TX bytes:26424 (25.8 KiB)
Interrupt:56

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:174 errors:0 dropped:0 overruns:0 frame:0
TX packets:174 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:13216 (12.9 KiB) TX bytes:13216 (12.9 KiB)

usb0 Link encap:Ethernet HWaddr 56:5B:87:1D:DF:42
inet addr:192.168.7.2 Bcast:192.168.7.3 Mask:255.255.255.252
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr 80:1F:02:AB:A5:A6
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
`

`
root@beaglebone:~# iwconfig
wlan0 unassociated Nickname:“WIFI@REALTEK
Mode:Managed Frequency=2.412 GHz Access Point: Not-Associated
Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lo no wireless extensions.

eth0 no wireless extensions.

usb0 no wireless extensions.
`

root@beaglebone:~# **lsusb** Bus 001 Device 002: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS] Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

root@beaglebone:~# **lsmod** Module Size Used by ip_tables 8294 0 x_tables 15072 1 ip_tables g_multi 55905 2 libcomposite 15228 1 g_multi 8192cu 443598 0 rfcomm 25106 0 ircomm_tty 14503 0 ircomm 8846 1 ircomm_tty irda 89974 2 ircomm_tty,ircomm ipv6 229989 28 hidp 10112 0 bluetooth 146100 4 hidp,rfcomm rfkill 16510 3 bluetooth autofs4 17432 2

`
root@beaglebone:~# cat /etc/network/interfaces

/etc/network/interfaces – configuration file for ifup(8), ifdown(8)

The loopback interface

auto lo
iface lo inet loopback

Wireless interfaces

iface wlan0 inet dhcp
wireless_mode managed
wireless_essid any
wpa-driver wext
wpa-conf /etc/wpa_supplicant.conf

iface atml0 inet dhcp

Wired or wireless interfaces

auto eth0
iface eth0 inet dhcp
iface eth1 inet dhcp

Ethernet/RNDIS gadget (g_ether)

… or on host side, usbnet and random hwaddr

iface usb0 inet static
address 192.168.7.2
netmask 255.255.255.0
network 192.168.7.0
gateway 192.168.7.1

Bluetooth networking

iface bnep0 inet dhcp
`

`
root@beaglebone:~# cat /etc/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
update_config=1

network={
key_mgmt=NONE
}
`

`
root@beaglebone:~# cat /var/lib/connman/settings
[global]
Timeservers=0.angstrom.pool.ntp.org;1.angstrom.pool.ntp.org;2.angstrom.pool.ntp.org;3.angstrom.pool.ntp.org
OfflineMode=false

[Wired]
Enable=true

[WiFi]
Enable=true

`

`
root@beaglebone:~# cat /var/lib/connman/wifi.config
[service_home]
Type=wifi
Name=WLAN-4F2046
Security=wpa
Passphrase=egalegal

`

I really hope somebody could help me, I’m freaking out since 3 days …

dmesg.txt (68.3 KB)

My solution was finally to disable HDMI. Now it works with built-in driver.

Other steps without success was:

  • update to current angstrom image
  • compile rtl8192cu from source
  • attach usb dongle with extend. cable
  • disable WPA2, make AP open

How do you power your board? USB or +5V?

How do you power your board? USB or +5V?

I use +5V power supply with 2,5A

I got it working, finally, following these instructions:
http://www.codealpha.net/864/how-to-set-up-a-rtl8192cu-on-the-beaglebone-black-bbb/

but, replacing:



<br>wpa_passphrase YourSSID YourPassphrase<br>

with (taken from steps here: http://linuxcommando.blogspot.com/2013/10/how-to-connect-to-wpawpa2-wifi-network.html)

wpa_passphrase gorilla >> /etc/wpa_supplicant.conf

(obviously, change gorilla, with your ssid)

then, the trick was to the following:

Edit /var/lib/connman/wifi.config and set it to the following



<br>[service_home]<br>Type=wifi<br>Name=YourSSID<br>Passphrase=YourEncryptedPassphrase<br>

For my WPA2-PSK access point, the “YourEncryptedPassphrase” is the Base64 string containing the PSK derived from the passphrase
e.g. for gorilla it was:

$ cat /etc/wpa_supplicant.conf 
# reading passphrase from stdin
network={
	ssid="gorilla"
	#psk="testtest"
	psk=4dfe1c985520d26a13e932bf0acb1d4580461dd854ed79ad1a88ec221a802061
}

As I remember, someone in this group have explained about the usb wifi dongle will have the EMC problem with hdmi clock ?

http://www.elinux.org/Beagleboard:BeagleBoneBlack#WIFI_Adapters

Gerald