fresh boot..only cylon leds blinking...then powers down - everytime


I just got my new BeaglePlay and followed downloading a new image as instructed in the Quick Start Guide. After writing the image to a SD card, I inserted the card into the Play, held down the USR button and applied the USB-C cable between the Play and my USB 3 port on my laptop. There’s a red led (power) and an orange (VL) led that lights up. The green leds light up and scroll back and forth (cylon) for several minutes) and then the whole unit powers down.

Does anyone know what might be the possible cause for this issue?
Thank you.


Now remove the microSD, remove power, then insert power. Board will boot with it’s newly flashed eMMC…


I’m having this problem as well with the latest image (Debian 11 - 2023-4-4). Perhaps I’m missing something basic. I have two other Beagleboards, a blue and the first ai board, and I was able to get both working on my network by just loading the latest image to a sdcard and booting it, then connecting via ssh over Ethernet.

This doesn’t seem to work for the Play, it does not show up on the network and does exactly what the OP posted here. But I’m not flashing the eMMC–just loading an sdcard and powering the board up via usb-c. The usb-c is connected to my Linux host computer also running Debian and unlike my other boards, does not load a drive.

Can some kinds soul tell me what silly thing I’m not doing?

please state the exact file name of the image.


Please retry with: Debian 11.x (Bullseye) - Monthly Snapshots (ARM64)

This would be similar to that one:

We tried doing the BeaglePlay in hidden git repos, and then when transitioning to public images, i don’t think that first week (Feb time frame) i had everything synced up properly…


Btw, I came to that image from the docs. It lead me here:

So, I’m probably not the only new person to be trying to use it.

Thank you. One more very basic question though. What is the difference between using the eMMC flasher image and the microSD image? My normal workflow is to get it all working on a sdcard and then flash it later to eMMC when changes are minimal. My thoughts being that I can always buy another sdcard, but I can’t replaced the onboard eMMC.

In a few months, we can go back to that workflow… Right now, the biggest issue is replacing the version of u-boot on the eMMC, and updating the cc1352 to a better firmware release. Once you do that, feel free to use the 2023-05-03 non-flasher.


So… the eMMC image automatically flashes? Do you still need to hold down the boot button?

on the play, you should not have to hold down the boot button, with a factory fresh eMMC…

Just plug in power, a cylon pattern should start in under 30seconds…


1 Like

Thank you. The 2023-05-03 flasher image linked above worked perfectly. I flashed the eMMC, removed the card, and the BeaglePlay board appeared on the network as expected.

Someone with the ability to do so should probably update that link on the Getting Started site to point to this one.

1 Like