gdb issue


I’ve been following Derek Molloy’s videos for the Beaglebone Black.
I’m trying to get Eclipse set up to remotely debug C/C++ on the BBB.
As far as I can tell, everything is configured properly.
I can SSH and automatically deploy my code to the target after it builds.

However, when I try to debug, I get an error saying: “readchar: Got EOF” and “Remote side has terminated connection. GDBServer will reopen the connection.”

I’ve been scouring the internet, but haven’t found any solution yet.
Any help would be greatly appreciated!


I found that that can happen when the gdbserver crashes, which can be caused by incompatible versions of gdbserver and gdb.


I verified the versions I have match what Mr. Molloy was using.

However, digging around in the forums, I was able to find someone else that had the same problem, and fixed it as follows:
Since I’m running virtualbox, and seeing the same symptoms as him, I’m going to try this solution tonight and see if it works.

Yay, resolved, C/C++ remote debugging in eclipse now working!

Thank you for all the help, in the end I changed the set-up of the virtualbox configuration, setting the network settings to:

“Bridged Adapter”.

I also installed:

sudo apt-get install lib32ncurses5

Now it works perfrectly.

I tried setting the virtualbox to “Bridged Adapter”; however, after that I could not ping the BBB.
Looks like I’m still in bad shape.

What’s really weird though is that I have selected the remote target (BBB) in the debug settings, but when I run, it looks like the project is actually running on the host, not the target…

Got it!
There’s a setting in the remote debug connection screen for “local” or “beaglebone”…somehow I missed this.
Anywho…set that, and now I’m debugging!