Getting Started on Mac w/Mountain Lion


Looks like this has been an issue in the past, but I don’t have the referenced tty connection when trying to connect to the board to complete the “eject” process as documented on the “Getting Started” page. System is 64-bit Mountain Lion, Beagle Bone v. A6a. Per the document, I didn’t install FTDI drivers…

Note: Driver installation is not required for rev A5 boards or newer. Check sticker on Ethernet port for revision.

I did attempt to install the drivers from the Board anyway after this, as well as latest drivers from ftdi website. I do get 2 devices that show up when the board is connected…


I appear to connect with ‘screen’ but nothing is being echoed back, so not sure I’m actually connected.

Did you use ‘screen /dev/tty.usbserial-TIVY8555B 115200’ and press once the screen cleared? You should see a login prompt at that point. I use Mountain Lion every day, so I’m confident it works.

Make sure you connect to /dev/tty.usb*B. The A port is the JTAG and will cause your board to reset when you press .

Thanks Jason, that worked. I was trying port A. Still not sure why the getting started guide indicates that you don’t need to install the FTDI drivers for A5 and later revs.