Getting Started

I am having a terrible time getting started with the beagle board. I
think I have tried everything in the getting started pages. I got
minicom to run on VMware with the Linux operating system, but the
computer just does not recognize anything on the serial port. For what
I understand all I should have to do is hook it up to a serial port
and select the location of what port I am using and it should spit out
something on hyperterminal, minicom, tera terminal, etc... but it just
doesn't give me a thing. I would greatly appreciate some help. Thanks

tseverance_21@hotmail.com wrote:

doesn't give me a thing. I would greatly appreciate some help. Thanks

Do you get a beep if you connect speakers to it? If so, then the u-boot
is running and you should get something in the serial console.

Also you should get a beagleboard logo to the screen if you connect a
LCD to it.

Have you checked these:
http://elinux.org/BeagleBoard#RS232
http://elinux.org/BeagleBoardFAQ#Serial_connection_.231

Make sure that you have a proper serial cable (should be a null-modem cable, if your setup is similar to mine), and that you have the baud rate set to 115200, with 8-bit, no parity. Then power the board off and back on, and see if you see anything output on the screen. If the cable and port are correct, you should see something, even if it is gibberish.

If you are using Windows, try teraterm without having VMware running, just in case VMware and Windows are fighting over the serial port.

Brett

I think that my problem is my cable hook up. I assumed I was suppose
to hook up every connection except for pin 10. But I see on that 3 pin
connection that 2 is hooked to three and three is hooked to 2 and then
pin 5 is hooked together. So this might be my problem. Thanks for your
help.

Also make sure the port is recognized correctly on the VMWare Linux
machine. For example I use a USB to Serial converter on my laptop, for
me the proceedure would be:

1. In VMWare, while running the linux vmware image, go to the VMWare
menu -> VM -> Removable Devices -> USB -> Select my USB-Serial Adapter
2. Inside The linux machine it should appear as /dev/ttyUSB0 or
something similar
3. configure minicom (Ctrl+A -> o for options) to use /dev/ttyUSB0 as
serial device
4. configure the baud rate and flow control settings (115200 8N1)
5. It should now work

I am assuming you are using a USB-Serial device, but if you are
running from a computer with a native serial port, be sure to add it
in the Virtual Machine Settings in VMWare.

Let us know how it goes!

Sincerely,
Alberto

Thanks a lot for all of your input, you have helped me out
tremendously. I guess I just need to read the articles a bit more
carefully. Thanks again!

Sevey

Problem might be your computer serial port in not working!. Check your CPU serial port and the serial cable by following beagle board reference manual chapter 13.3.

Sathish