GPIO default pin level

I have been spending some time trying to understand device tree overlays. Currently my uEnv.txt is configured so that:

`

##BeagleBone Black: HDMI (Audio/Video) disabled:
dtb=am335x-boneblack-emmc-overlay.dtb

`

`

cat /sys/devices/platform/bone_capemgr/slots
0: PF---- -1
1: PF---- -1
2: PF---- -1
3: PF---- -1
4: P-O-L- 0 Override Board Name,00A0,Override Manuf,univ-emmc

`

I would like to keep the GPIOs that default as PIN_OUTPUT_PULLUP from doing so, and would prefer them to pulldown.

What is the best way to go about doing that?

I have made progress on this and have a .dtbo that I can load manually and set all of my gpio in the desired state I am looking for.

My issue now is getting this overlay to load on boot. Here is my uEnv.txt:

`

uname_r=4.4.113-ti-r149

enable_uboot_overlays=1
dtb_overlay=/lib/firmware/univ-emmc-smb-00A0.dtbo
disable_uboot_overlay_video=1
disable_uboot_overlay_audio=1
disable_uboot_overlay_wireless=1

cmdline=coherent_pool=1M net.ifnames=0 quiet cape_universal=enable

`

I can manually load the overlay by:

`

root@beaglebone:/lib/firmware# echo univ-emmc-smb > $SLOTS

`

Bootloader version:

`
bootloader:[microSD-(push-button)]:[/dev/mmcblk0]:[U-Boot 2018.09-00002-gd5b4c4b656]:[location: dd MBR]

`

What am I missing?

I resolved this by disabling the old version of the u-boot bootloader on the eMMC: (a step suggested in anothe rpost I had here https://forums.adafruit.com/viewtopic.php?f=49&t=142107)

`
sudo dd if=/dev/zero of=/dev/mmcblk1 bs=1M count=10

`