GPIO high during boot

Hello,

I’m using the BeagleBone Black’s GPIOs to drive some outputs.
I’m running Kernel 3.8, so I used the Device Tree to configure the GPIOs. The cape is loaded during boot via the capemgr.
But until the BBB has fully booted, some of the GPIOs are set to high.
Is there a way to prevent this?

Regards,
Nils

make it pull up in uboot
or
use as fixedregulator

regulators {
compatible = “simple-bus”;

reg_3p3v: 3p3v {
compatible = “regulator-fixed”;
regulator-name = “3P3V”;
regulator-min-microvolt = <3300000>;
regulator-max-microvolt = <3300000>;
regulator-boot-on;
regulator-always-on;
gpio = <&gpio3 23 0> ,<&gpio3 20 0>;

How do I change the Pullup settings in uboot?

I guess I have to edit /board/ti/am335x/board.h, right?
But what do I actually have to change?

No

http://git.denx.de/?p=u-boot.git;a=blob;f=board/genesi/mx51_efikamx/efikamx.c;h=6ba55cd08a82f62a5cd420b024ff68cdb0cc171a;hb=HEAD

This is a reference for u-boot