gst-launch gives the following error: Processor_create_d> Loading and starting DSP server '/usr/share/ti/ti-codecs-server/cs.x64P' FAILED, status=[0x80008008]


I'm trying to use gst-launch to decode a video. I'm using:
* Angstrom Demo image(kernel 2.6.32), completely unchanged. Only
installed the native toolchain and gstreamer-ti packages.
* Beagleboard rev C4.
* I added this to the bootargs to create a memory hole:
mem=99M@0x80000000 mem=128M@0x88000000
* The pipeline used (Also tried others..): gst-launch -v filesrc
location=sample.m4v ! TIViddec2 codecName=mpeg4dec
engineName=codecServer ! TIDmaiVideoSink videoStd=VGA videoOutput=LCD

I already made sure the cs.x64P file exists. I also made sure with
dmesg that the kernel modules are initialized correctly during the
init process.

I would truly appreciate any help regarding this matter. Attached
below is the complete debugging information returned after setting


What happens if you do:

gst-launch -v filesrc location=sample.m4v ! TIViddec2 ! omapfbdmaisink




Essentially I'm getting: 'WARNING: erroneous pipeline: no element

Here's the full output:


Try omapdmaifbsink, I get dyslexic from all those elements :slight_smile:

It's much better now, but I'm getting an error regarding the display:

It's much better now, but I'm getting an error regarding the display:
Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
WARNING: from element /GstPipeline:pipeline0/
GstOmapFbSink:omapfbsink0: Could not initialise X output
Additional debug info:
omapfb.c(276): gst_omapfbsink_xcontext_get (): /GstPipeline:pipeline0/
Could not open display

It should fallback to plain framebuffer, does it do that or not?

At least some progress finally. I wonder what was the problem with the
other sink?

All the extra options like codecname behave differently on all platforms, I try to avoid them as much as possible. Dmaivideosink is also "special" in its expectations of how the system looks.



What do you mean by 'it should fallback to plain framebuffer'. What I
mean is, what am I expected to see, as nothing really happens. I also
tried doing 'export DISPLAY=:0' which caused this error to disappear,
but still nothing really happens.

Thanks again,