Have an IP address but cannot connect to internet

Hi,

I need internet connection on my beagleboard xm and decided to tether my phone’s internet. However even though I got an IP address, I cannot ping to google.com.

root@beagleboard:~# ifconfig -a
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

usb0 Link encap:Ethernet HWaddr 9A:BF:F8:89:0D:C9
inet6 addr: fe80::98bf:f8ff:fe89:dc9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:25 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:5756 (5.6 KiB)

usb1 Link encap:Ethernet HWaddr 56:84:5B:34:3B:BC
inet addr:192.168.42.63 Bcast:192.168.42.255 Mask:255.255.255.0
inet6 addr: fe80::5484:5bff:fe34:3bbc/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3 errors:0 dropped:0 overruns:0 frame:0
TX packets:25 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:689 (689.0 b) TX bytes:6124 (5.9 KiB)

While I was using beaglebone, this issue was related to DNS and I was able to solve the problem by adding nameserver 8.8.8.8 to the /etc/resolv.conf. However this time it did not work. Do you have any suggestions?

Also when I boot the device I get the following error:

Failed to bring up eth0.
usb0 no wireless extensions.

Internet Systems Consortium DHCP Client 4.1.1-P1
Copyright 2004-2010 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

can’t create /var/lib/dhcp/dhclient.usb0.leases: No such file or directory
Listening on LPF/usb0/9a:bf:f8:89:0d:c9
Sending on LPF/usb0/9a:bf:f8:89:0d:c9
Sending on Socket/fallback
DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 9

DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 16

DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 16
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
done.

Is "can’t create /var/lib/dhcp/dhclient.usb0.leases: No such file or directory" error an important thing?

Regards,
Amadeus

I am pretty sure that it is related to DNS settings. But I could not find a solution. Any assitance will be much appreciated.

2 Ekim 2012 Salı 16:01:43 UTC+3 tarihinde zero yazdı:

if usb0 is wireless adaptor, then iwconfig usb0 you should see something.
but now usb0 is not up. but your usb1 is ok for internet now. do you send
me your routing table? ( command: route -n)

Cheers,

zero <satanasxentius@gmail.com> [12-10-02 16:04]:

I am pretty sure that it is related to DNS settings. But I could not find a
solution. Any assitance will be much appreciated.

2 Ekim 2012 Salı 16:01:43 UTC+3 tarihinde zero yazdı:
>
> Hi,
>
> I need internet connection on my beagleboard xm and decided to tether my
> phone's internet. However even though I got an IP address, I cannot ping to
> google.com.
>
> *root@beagleboard:~# ifconfig -a*
> *lo Link encap:Local Loopback*
> * inet addr:127.0.0.1 Mask:255.0.0.0*
> * inet6 addr: ::1/128 Scope:Host*
> * UP LOOPBACK RUNNING MTU:16436 Metric:1*
> * RX packets:0 errors:0 dropped:0 overruns:0 frame:0*
> * TX packets:0 errors:0 dropped:0 overruns:0 carrier:0*
> * collisions:0 txqueuelen:0*
> * RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)*
> *
> *
> *usb0 Link encap:Ethernet HWaddr 9A:BF:F8:89:0D:C9*
> * inet6 addr: fe80::98bf:f8ff:fe89:dc9/64 Scope:Link*
> * UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1*
> * RX packets:0 errors:0 dropped:0 overruns:0 frame:0*
> * TX packets:25 errors:0 dropped:0 overruns:0 carrier:0*
> * collisions:0 txqueuelen:1000*
> * RX bytes:0 (0.0 b) TX bytes:5756 (5.6 KiB)*
> *
> *
> *usb1 Link encap:Ethernet HWaddr 56:84:5B:34:3B:BC*
> * inet addr:192.168.42.63 Bcast:192.168.42.255
> Mask:255.255.255.0*
> * inet6 addr: fe80::5484:5bff:fe34:3bbc/64 Scope:Link*
> * UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1*
> * RX packets:3 errors:0 dropped:0 overruns:0 frame:0*
> * TX packets:25 errors:0 dropped:0 overruns:0 carrier:0*
> * collisions:0 txqueuelen:1000*
> * RX bytes:689 (689.0 b) TX bytes:6124 (5.9 KiB)*
>
>
> While I was using beaglebone, this issue was related to DNS and I was able
> to solve the problem by adding nameserver 8.8.8.8 to the /etc/resolv.conf.
> However this time it did not work. Do you have any suggestions?
>
> Also when I boot the device I get the following error:
>
>
> *Failed to bring up eth0.*
> *usb0 no wireless extensions.*
> *
> *
> *Internet Systems Consortium DHCP Client 4.1.1-P1*
> *Copyright 2004-2010 Internet Systems Consortium.*
> *All rights reserved.*
> *For info, please visit https://www.isc.org/software/dhcp/*
> *
> *
> *can't create /var/lib/dhcp/dhclient.usb0.leases: No such file or
> directory*
> *Listening on LPF/usb0/9a:bf:f8:89:0d:c9*
> *Sending on LPF/usb0/9a:bf:f8:89:0d:c9*
> *Sending on Socket/fallback*
> *DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 4*
> *DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 4*
> *DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 8*
> *DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 20*
> *DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 9*
> *DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 16*
> *DHCPDISCOVER on usb0 to 255.255.255.255 port 67 interval 16*
> *No DHCPOFFERS received.*
> *No working leases in persistent database - sleeping.*
> *done.*
> *
> *
>
> Is "*can't create /var/lib/dhcp/dhclient.usb0.leases: No such file or
> directory" *error an important thing?
> *
> *
>
>
> Regards,
> Amadeus
>
>

--

Hi zero,

this is definetly a shot in the dark...

I own a Beaglebone and network-wise it should be identical
to the Beagleboard.

When I do a ifconfig on the Beaglebone I see this:
beaglebone:/root>ifconfig

eth0 Link encap:Ethernet HWaddr d4:94:a1:99:9b:82
          inet addr:192.168.178.25 Bcast:192.168.178.255 Mask:255.255.255.0
          inet6 addr: fe80::d694:a1ff:fe99:9b82/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:28504 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24724 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2190512 (2.0 MiB) TX bytes:1755122 (1.6 MiB)

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:100 (100.0 B) TX bytes:100 (100.0 B)

I am using old school cable to connect to the internet, therefore
there is an old fashioned "eth0".

But: There is no inet6 address...which can be seen at the output
of ifconfig in you email.

Secondly: You should not use Googles DNS. Use the DNS of your Internet
provider or the one he suggests.

Thirdly: Is it possible that the eth0 is tried to bring up BEORE the
usb wireless module gets loaded?
Compile the stuff for wireless eth access directly into your kernel
instead.

HTH!
Best regards,
mcc

Hello goldpeer,

Here are the outputs:

root@beagleboard:~# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.42.0 0.0.0.0 255.255.255.0 U 1 0 0 usb1
0.0.0.0 192.168.42.129 0.0.0.0 UG 0 0 0 usb1
root@beagleboard:~# cat /etc/resolv.conf

Generated by NetworkManager

nameserver 192.168.42.129

2 Ekim 2012 Salı 17:15:33 UTC+3 tarihinde goldpeer yazdı:

which port is your internet connection? usb0 or usb1?

from your routing table, usb1 should be a working connection.

can you ifconfig usb0 up manually? if not, it means network driver
for usb0 is not working.

sorry but I could not clearly understand which port is my internet connection. I am think it is usb0. But to be sure here are some outputs that may help you:

root@beagleboard:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 002 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 002 Device 004: ID 0bb4:0ffe High Tech Computer Corp.

root@beagleboard:~# dmesg

[ 6890.519561] usb 2-2.1: new high speed USB device using ehci-omap and address 3
[ 6890.652862] usb 2-2.1: New USB device found, idVendor=0424, idProduct=ec00
[ 6890.660003] usb 2-2.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 6890.672058] smsc95xx v1.0.4
[ 6890.733886] usb0: register ‘smsc95xx’ at usb-ehci-omap.0-2.1, smsc95xx USB 2.0 Ethernet, b2:e5:48:44:72:4b
[ 6890.824188] usb 2-2.4: new high speed USB device using ehci-omap and address 4
[ 6890.962982] usb 2-2.4: New USB device found, idVendor=0bb4, idProduct=0ffe
[ 6890.970001] usb 2-2.4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 6890.978515] usb 2-2.4: Product: Android Phone
[ 6890.982971] usb 2-2.4: Manufacturer: HTC
[ 6890.986907] usb 2-2.4: SerialNumber: HT9CHL902279
[ 6891.021240] usb1: register ‘rndis_host’ at usb-ehci-omap.0-2.4, RNDIS device, 56:84:5b:34:3b:bc
[ 6891.245697] udev: starting version 151
[ 6891.497741] Restoring csi2 context
[ 6892.864868] Saving csi2 context
[ 6892.901214] cfg80211: Using static regulatory domain info
[ 6892.923889] cfg80211: Regulatory domain: 00
[ 6892.943695] (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 6892.951354] (2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 6892.958496] (2457000 KHz - 2482000 KHz @ 20000 KHz), (600 mBi, 2000 mBm)
[ 6892.965606] (2474000 KHz - 2494000 KHz @ 20000 KHz), (600 mBi, 2000 mBm)
[ 6892.972717] (5170000 KHz - 5250000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 6892.980560] (5735000 KHz - 5835000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 6892.987701] cfg80211: Calling CRDA to update world regulatory domain
[ 6900.063385] usbcore: registered new interface driver rndis_wlan
[ 6908.455718] Bluetooth: Core ver 2.15
[ 6908.460968] NET: Registered protocol family 31
[ 6908.465728] Bluetooth: HCI device and connection manager initialized
[ 6908.472381] Bluetooth: HCI socket layer initialized
[ 6908.499603] Bluetooth: L2CAP ver 2.14
[ 6908.503601] Bluetooth: L2CAP socket layer initialized
[ 6908.530181] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
[ 6908.670867] NET: Registered protocol family 10
[ 6908.731567] irda_init()
[ 6908.731597] NET: Registered protocol family 23
[ 6908.751800] IrCOMM protocol (Dag Brattli)
[ 6908.848327] Bluetooth: RFCOMM TTY layer initialized
[ 6908.853240] Bluetooth: RFCOMM socket layer initialized
[ 6908.858520] Bluetooth: RFCOMM ver 1.11
[ 6925.238006] usb0: no IPv6 routers present
[ 6993.620819] usb1: no IPv6 routers present

2 Ekim 2012 Salı 17:38:43 UTC+3 tarihinde goldpeer yazdı:

Is not my usb0 aldready up? But I tried ifconfig usb0 down && ifconfig usb0 up anyway and did not solve anything. Also is not my internet connection over usb1? IP address info is written under usb1?

2 Ekim 2012 Salı 17:38:43 UTC+3 tarihinde goldpeer yazdı:

usb0: is normally the usb "otg" connector on Beagle xM
usb1: was formerly the "smsc95xx" Ethernet jack, in later kernels this
became eth0

Regards,

I do not have a logical answer to your question because of my ignorance but I am not using an USB wireless module to connect to internet. I am using an USB cable to tether my internet connection. Therefore I think it should not be a problem?

2 Ekim 2012 Salı 17:17:22 UTC+3 tarihinde Meino....@gmx.de yazdı:

Is it OK that at the dmesg output I see that:

[ 9648.259857] usb0: no IPv6 routers present
[ 9714.064544] usb1: no IPv6 routers present

no. dmesg shows that usb0 should be ethernet, [ 6890.733886] usb0: register ‘smsc95xx’ at usb-ehci-omap.0-2.1, smsc95xx USB 2.0 Ethernet, b2:e5:48:44:72:4b

usb1 is something else. you’d better change your cable tether to your mobile(?)
into another usb port for a trial?

Cheers,

Dan

Dan, now I connected my phone to PC and everything worked well. Also I tried other 3 USB ports on my beagleboard-xm but unfortunately nothing changed.

2 Ekim 2012 Salı 18:20:04 UTC+3 tarihinde goldpeer yazdı:

I really do not know how this happened:

root@beagleboard:~# ping google.com
PING google.com (173.194.39.32): 56 data bytes
64 bytes from 173.194.39.32: icmp_seq=0 ttl=40 time=65.735 ms
64 bytes from 173.194.39.32: icmp_seq=1 ttl=40 time=64.637 ms
64 bytes from 173.194.39.32: icmp_seq=2 ttl=40 time=65.463 ms
^C— google.com ping statistics —
4 packets transmitted, 3 packets received, 25% packet loss
round-trip min/avg/max/stddev = 64.637/65.278/65.735/0.467 ms

I was tethering my wifi connection from the cell-phone. Then, I decided to give 3g a try and it worked. Then I enabled wireless and tethered it. Now it is working also. But if I directly try to tether my wireless connection, it does not work. (I should go step by step.)

Is not it strange? Do you have idea what kind of a logic is behind this?

Good to hear about you got it-:slight_smile:

OMG! I will go nuts. It worked for two times. But now it is not working again.

What I have done was to opkg update && opkg upgrade. I could not even successfully do. it I got following errors: (probably due to lack of internet connection.)

Collected errors:

I am pretty sure that: I have internet connection on my cell-phone, power enable mode is not enabled on my cell phone which can disable wifi connection, everything works fine on my laptop. (Tried about 30 minutes and did not encounter any problems.)

Does beagleboard-xm has some kind of a power save mode which can disable internet connection after a certain time?