Having trouble filing an RMA for a BBB though the site


I am having issues filing an RMA through Beaglebone’s main site. I have a BBB Rev C that’s suffering boot problems, but it’s hard for me to describe what’s wrong.

Here is what I was a planing to describe the problem in the RMA as.

“The board was working fine out of the box. I was able to log in via USB ssh. However, I tried using an HDMI cable to connect it to the TV and was supplying power from the USB (an adapter for a tablet with 2A of possible current draw, not my computer, I later learned that this was a big mistake and I should have been using the barrel connector). It was working for a few minutes, then harshly shut down. When trying to reboot it without an SD card, all of the lights power on, and go for about 2 seconds, and then immediately die. I figured that the boot loader was corrupted so I tried to boot from a microSD card (16 gigabytes) and it still suffered from the same issue. I tried reflashing it with the latest version of Angstrom on the site, but the Beaglebone Black never seems to complete (I’m not even sure it if it even starts) the reflashing. It does stay on when the reflashing microSD is inserted, but only the LED that indicates CPU activity and the heart beat pattern are active. It never finishes by giving all four LEDS as on even after several hours of the flashing process. I am unable to access it from my computer’s usb because it always instantly dies.”

And that’s the gist of my problem.

So I read a lot of forum posts, and the boards that Gerald recommended an RMA for sounded much worse than mine. I don’t think my processor is fried, but I don’t think I know enough about the BBB to say if it is a hardware issue or a software issue. I’m approaching my 90 day window soon (I bought it for a class in embedded electronics back in August) and I don’t want to tamper with it more than I already have trying to resuscitate it.

However, upon trying to do an RMA in Google chrome, the submission form hangs when I press submit. Nothing happens, not even an indication of loading or processing. I have adblocker but I had it disabled to do the RMA. That’s about the only chrome extension I have. I also logged into my gmail account on the Beaglebone site and it still produced the same results. So I tried doing the RMA via Firefox, and everything was working great until I got to the webmail handler. I chose gmail and it took me to a gmail page that read " Invalid Request". So I tried doing the RMA from Internet Explorer, also logged into the Beaglebone site, and when I tried to submit it, an exception was thrown that said “Could not preform this operation because the default Mail Client is not properly installed.”

Is there anyways I can send an RMA request directly through Email or something of the sort? If it’s any relevant info, I bought my board from Arrow Electronics on August 10th, 2014.

Any help would be greatly appreciated,


I found the solution to my problem with some help of a class mate. It was all a software issue. I was able to conclude that my SD card that I was using for reflashing had actually been partitioned before (long ago, while I was flashing a phone or something of that nature) and the reason my image for reflashing didn’t work was because I had less than 100 Megabytes on the SD card available to Windows to write to. I used a guide with the DISKPART tool to wipe the SD card and re wrote the Angstrom eMMC flashing image back on the card. This time the process went to completion and the BBB appears to be unscathed.

Thus, I require no extra support. Should I delete this post or leave it up?


You can just delete if you wish.