HDMI issue

A newbie here… Just got a new BBB rev C. and am having HDMI issues. I am able to boot it by after I get into X the monitor (Dell 1907) goes into powersave mode. I have tried also rebooting w/out the HDMI to VGA converter plugged in and then plugging in the cable. I get the graphical display for about 5 seconds and then it goes into power save mode again. It doesn’t appear I can turn this off power save on the monitor, can I do this on the board itself or other ideas?


So is "hdmi" or is "vga"... because "analog" isn't in the hdmi spec..
There are "aftermarket" adapters to do it..


Can you plug it into a TV?
It will detect the capabilities of the monitor / TV it is plugged into.
It may be trying to output a resolution / refresh frequency the monitor can’t handle, but the TV will be at a lower resolution.
At least you will be able to see the screen.

Answering both questions and thanks for the responses.

I purchased a micro HDMI to VGA converter on Amazon (http://www.amazon.com/gp/product/B00879EZJI/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1) and it seems to work fine. I can see the system briefly at boot up as well as when it goes into X but after about 5 seconds the display goes into powersave mode. I’ll have to look and see if I have a VGA port on any of my TV’s, otherwise, I don’t have an adapter.

I am able to SSH into the system using the USB cable and my Macbook. Is there a way I can set it to a low resolution that both BBB supports and the monitor. I tried modifying the uEnv.txt file per the BBB HDMI support wiki but then I saw that’s only for the boot sequence. Is there another way to force this?

Thanks again,

Try connecting to the TV without the VGA adapter.
Hopefully your TV or VCR has HDMI inputs.
Most modern monitors have HDMI inputs too.
The idea is to get it up and visible so you can adjust the resolution to a lower one you know the VGA can handle.

Thanks Peter, I will give that a try if I can find a cable. I was just thinking that if there’s a config file I could modify via SSH I might be able to try out the same idea of adjusting resolutions w/out buying another cable. I just don’t know which config file to modify.

Also, FYI - I tried another monitor here at work and it did the same thing.

There is a way to force the HDMI while it is running.
Do a google,search for: beaglebone HDMI
Here is an excerpt:

Forcing A Resolution
It is possible to force a resolution to be used by the board. The availble resolutions will however, be limited to those that have been determined to work by the DRM manager on the board. As a result, not all resolutions that can be supported by the display are available. But, it will allow you to try other resolutions.
You will need the following items:
1) FTDI Serial Cable
2) Putty, Teraterm, or similar terminal emulation software.
1) Connect the serial cable to your PC.
2) Launch the terminal emulation SW and select the correct serial port.
3) Connect the serial cable to the serial debug connector on the board.
4) Connect the HDMI cable to the board and your display.
5) Apply power to the board.
6) You should see messages appear on the terminal.
7) When the login prompt appears type root and hit enter.
8) Type export XAUTHORITY=`ls /var/run/gdm/auth-for-root-*/database` and hit enter.
9) Type export DISPLAY=:0.0 and hit enter.
10) Type xrandr --output HDMI-0 --mode 720x480 --rate 60. You can substitute different resolutions and refresh rates if you like. Hit enter.

The resolution should change on the display. If you get the message "xrandr: cannot find mode 1920x1080" where the 1920x1080 in this example is the mode you selected, that means that the DRM driver did not select it as an available resolution.

You can coerce the DRM's view of allowed resolutions using kernel
command line flags, including non-standard options. I had to do this
for some small LCD panels that lied about their resolution in the EDID
(800x480 LCD that claimed it was full HD 720P):



The beaglebone has a thermal fuse that trips when more than 100ma is drawn by anything plugged into the micro HDMI connector. Most HDMI to VGA converters draw quite a bit more than that. Either use an externally powered converter or replace the 100mA RT1 device found on the beaglebone (just behind the large USB connector) with a higher current device like an RXEF025 or RXEF050 (the will end any hopes you may have for a warranty on the beaglebone but it worked well enough for me.) You could even take out the RT1 device and put a small wire jumper in its place. I also found it was very important to have something like kms_force_mode=video=HDMI-A-1:1024x768@60e in the uEnv.txt file for boot up since a lot of HDMI to VGA converters don’t send reliable HDMI information back to the beaglebone.
To get it to work in 1280x1024 mode, I had to add an M before the @ to get kms_force_mode=video=HDMI-A-1:1280x1024M@60e