HDMI output on Production Image 2013.06.20 goes beyond the edge of top/left of the display

I’m using the production image, 2013.06.20, listed as Cloud9 GNOME Image 2013.06.20 in /etc/dogtag. With the previous version on my BBB the hdmi to the same panel (same BBB, same cable etc) was within the bounds of the display. After upgrading to the 2013.06.20 image it looks like the top and left sides are off of the screen by a half inch or so (can’t be sure, might only be the top).



Have you tried changing the resolution in Angstrom? Under the display settings. It sounds like an over scan issue



I went to the dropdown (by guessing and click I found the settings menu) and it was 1920x1080, the next res down is 1280x720, neither of those work, the 1280x720 is also way beyond the size of the screen.


Go to your display options. Look for an option to disable overscan, fit image to page, or something similar.



I have the same problem on an A5A release board.

It has nothing to do with the display.
It has nothing to do with resolution.

It is the BBB itself.


Did it work better on a later rev board? I might have a a5b to test against.


It has nothing to do with the Hardware. It is a SW issue.

Late last week we found an issue where the processor cannot create the correct HDMI timings. With the help of the folks at NXP we have a fix for it, by setting a mode change in the NXP framer. The fix appears to work. Work is in process to get a patch pulled together suitable to push upstream. Once we have the patch, we will get it applied and a new image and get that out. I am hoping for something late this week to be available. But it depends on several things falling into place.


Is this a patch for Angstrom or for all distributions?

All that use the 3.8 kernel. It will affect the DRM driver.


Hi … I am using a uHDMI-HDMI cable to connect BeagleBone Black to my 1920x1200 display and managed to get a 1280x720 resolution working.

Problem is that the desktop area is slightly bigger than the display and after searching online I haven’t come across a solution to get the resolution to fit the display. I did find some (potentially) useful information for playing with video in alternative BBB distros (Debian) but I would first like to try and get this working in the default Angstrom.

I flashed the latest 2013.07.31 image but no difference from the previous 2013.06.20.

Thanks for any help!

Since your physical display has more pixels than the BeagleBone is
generating, you probably can't easily fix this on the 'Bone side (unless
you perhaps change resolutions to something your monitor likes better).

The issue is with the scaling in your display. Most displays consider
HDMI to be a video source and intentionally "overscan", or push a few
pixels off the screen to avoid displaying the far edges of the video
signal which often contain garbage in a "real" video signal. Depending
on your exact monitor, there may be a way to change the scaling to not
use overscan. Try the various "zoom" settings, and make sure you read
the manual for the monitor (look for the "how to connect a computer"

On my Samsung monitors (hooked to my regular x86 PC via HDMI), I have to
use a specific HDMI port *AND* set it to the "DVI PC" mode or it
stretches the image and puts some pixels off-screen.

Hi Charles … Thanks for pointing me in the right direction!

Turns out I needed to adjust the setting on my display to indicate “Image Setting->Video Mode->PC Mode” (formerly set to ‘Video Mode’). Now the 1280x720 desktop perfectly fits inside the borders of the display.