HDMI resolution not supported?


I have a beaglebone with which I am having trouble getting an HDMI output on a 50 inch tv. I am getting HDMI output on 32 inch TV but not on a 50 inch. It just says resolution not supported.
I have tried forcing different resolutions through uEnv.txt but that did not work.

What changes can I make to get HDMI output?

Any help would be greatly appreciated.

Thank you

Which resolutions did you try?

The BBB has a limited pixel clock frequency. The resolutions most
likely to work with your TV are 720p (60 Hz) and 1080i (60 frame/30
hz), since HDMI requires one of these resolutions to be supported by
any HDMI device capable of HD (per the HDMI 1.4b spec):

"An HDMI Sink that accepts 60Hz video formats, and that supports HDTV
capability shall support 1280x720p @ 59.94/60Hz or 1920x1080i @
59.94/60Hz video format timings."

If you're lucky, the TV will support 1080p30, which will typically
look better than 1080i, but this isn't an HDMI requirement.

Hi Charles,

I have tried all the resolutions mentioned in this website: https://elinux.org/Beagleboard:BeagleBoneBlack_HDMI

This is my boot log:

U-Boot 2018.09-00002-g0b54a51eee (Sep 10 2018 - 19:41:39 -0500), Build: jenkins5

CPU : AM335X-GP rev 2.1
I2C: ready
DRAM: 512 MiB
No match for driver ‘omap_hsmmc’
No match for driver ‘omap_hsmmc’
Some drivers were not found
Reset Source: Power-on reset has occurred.
RTC 32KCLK Source: External.
Loading Environment from EXT4… ** File not found /boot/uboot.env **

** Unable to read “/boot/uboot.env” from mmc0:1 **
Board: BeagleBone Black
not set. Validating first E-fuse MAC
BeagleBone Black:
BeagleBone: cape eeprom: i2c_probe: 0x54:
BeagleBone: cape eeprom: i2c_probe: 0x55:
BeagleBone: cape eeprom: i2c_probe: 0x56:
BeagleBone: cape eeprom: i2c_probe: 0x57:
Net: eth0: MII MODE
cpsw, usb_ether
Press SPACE to abort autoboot in 2 seconds
board_name=[A335BNLT] …
board_rev=[000C] …
switch to partitions #0, OK
mmc0 is current device
SD/MMC found on device 0
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1…
gpio: pin 56 (gpio 56) value is 0
gpio: pin 55 (gpio 55) value is 0
gpio: pin 54 (gpio 54) value is 0
gpio: pin 53 (gpio 53) value is 1
switch to partitions #0, OK
mmc0 is current device
gpio: pin 54 (gpio 54) value is 1
Checking for: /uEnv.txt …
Checking for: /boot.scr …
Checking for: /boot/boot.scr …
Checking for: /boot/uEnv.txt …
gpio: pin 55 (gpio 55) value is 1
2120 bytes read in 12 ms (171.9 KiB/s)
Loaded environment from /boot/uEnv.txt
Checking if uname_r is set in /boot/uEnv.txt…
gpio: pin 56 (gpio 56) value is 1
Running uname_boot …
loading /boot/vmlinuz-4.14.71-ti-r80 …
10416640 bytes read in 667 ms (14.9 MiB/s)
debug: [enable_uboot_overlays=1] …
debug: [enable_uboot_cape_universal=1] …
debug: [uboot_base_dtb_univ=am335x-boneblack-uboot-univ.dtb] …
uboot_overlays: [uboot_base_dtb=am335x-boneblack-uboot-univ.dtb] …
debug: unable to find [am335x-boneblack-uboot-univ.dtb] using [am335x-boneblack.
debug: [uboot_base_dtb_univ=am335x-boneblack-uboot.dtb] …
uboot_overlays: [uboot_base_dtb=am335x-boneblack-uboot.dtb] …
loading /boot/dtbs/4.14.71-ti-r80/am335x-boneblack.dtb …
60317 bytes read in 18 ms (3.2 MiB/s)
uboot_overlays: [fdt_buffer=0x60000] …
uboot_overlays: loading /lib/firmware/BB-BONE-eMMC1-01-00A0.dtbo …
1440 bytes read in 26 ms (53.7 KiB/s)
uboot_overlays: loading /lib/firmware/BB-HDMI-TDA998x-00A0.dtbo …
5127 bytes read in 33 ms (151.4 KiB/s)
uboot_overlays: loading /lib/firmware/BB-ADC-00A0.dtbo …
711 bytes read in 254 ms (2 KiB/s)
uboot_overlays: loading /lib/firmware/AM335X-PRU-RPROC-4-14-TI-00A0.dtbo …
3513 bytes read in 44 ms (77.1 KiB/s)
uboot_overlays: loading /lib/firmware/univ-bbb-EVA-00A0.dtbo …
61976 bytes read in 171 ms (353.5 KiB/s)
loading /boot/initrd.img-4.14.71-ti-r80 …
4739448 bytes read in 308 ms (14.7 MiB/s)
debug: [console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/m.
debug: [bootz 0x82000000 0x88080000:485178 88000000] …

Flattened Device Tree blob at 88000000

Booting using the fdt blob at 0x88000000
Loading Ramdisk to 8fb7a000, end 8ffff178 … OK
reserving fdt memory region: addr=88000000 size=7e000
Loading Device Tree to 8faf9000, end 8fb79fff … OK

Starting kernel …

[ 0.001586] timer_probe: no matching timers found
[ 1.102494] wkup_m3_ipc 44e11324.wkup_m3_ipc: could not get rproc handle
[ 1.403763] omap_voltage_late_init: Voltage driver support not added
[ 1.411113] PM: Cannot get wkup_m3_ipc handle
[ 1.813307] i2c i2c-0: Failed to register i2c client tda998x at 0x70 (-16)
[ 1.820327] i2c i2c-0: of_i2c: Failure registering /ocp/i2c@44e0b000/tda19988
[ 1.836928] hdmi-audio-codec hdmi-audio-codec.0.auto: ASoC: no source widgetk
[ 1.845906] hdmi-audio-codec hdmi-audio-codec.0.auto: ASoC: Failed to add roX
[ 1.875666] musb-hdrc musb-hdrc.1: VBUS_ERROR in a_wait_vrise (80, <SessEnd)c

Debian GNU/Linux 9 beaglebone ttyS0

BeagleBoard.org Debian Image 2018-10-07

Support/FAQ: http://elinux.org/Beagleboard:BeagleBoneBlack_Debian

default username:password is [debian:temppwd]

beaglebone login: