HELP. dead beagleboneblack

Hi. I bought BBB A6A new, 1 month ago. It worked OK out-of-the-box.
I power it from the USB from a windows laptop and poke around with a browser. No problems.
I soldered on the proper JTAG header very carefully and now it is dead.
The Power LED lights up, but nothing else happens.
I am handy with electronics, programming and linux.
What can I do to troubleshoot the BBB?
Is there a DIY procedure?
I did not reflash the eMMC or a SDcard.

thanks…dd

Well, I guess the stone-club method would be reflashing the BBB, sorry I can’t help.

I would try reflashing the eMMC, assuming that the solder job is as good as you say it is.

Gerald

ok! that worked. we r back in action. thx…dd

If Power LED still lights up, that means no short happens. JTAG header has two reset signals: nSRST (system reset) and nTRST (JTAG reset). I believe one of these two pins must be connected incorrectly. You might try to dis-soldered the header first and see whether the BBB can work then.

Hi,

The problem is the same after JTAG header soldered. But Power LED not lighting up while powered up through USB cable from laptop.
Is my BBB dead?

Yes it does sound like it is dead. If the power LED does not come on, that indicates that it has an issue. I suggest you try getting an RMA.

http://www.elinux.org/Beagleboard:BeagleBoneBlack#RMA_Support

Gerald