HELP - HELP - HELP

I made the wifi work as follows ...
1. I found the wifi drivers in Ubuntu and just copied the files to angstrom ...
2. I am not able to do the same with the ethernet not know where is the information, files, or the ethernet adapter in ubuntu so I can do the same.

Hi Diego,

What usb Ethernet adapter is this?

Usando o Google Translate:

Por favor, ligue para um adaptador USB Ethernet x86 pc e digite "lsusb".

Regards,

but I need it to angstrom

Hi Diego,

Please read, (its in Portuguese) :
http://www.celiojunior.com.br/comofazerperguntas.php

(translation of : http://catb.org/~esr/faqs/smart-questions.html)

For us to help you, we need information... dump lsusb/dmesg/serial boot etc..

Regards,

Hi Robert,

Even I am facing getting my wi-fi usb adapter work with Angstrom.
Its working with my ubuntu9.04 desktop PC, so I tried copying the
driver files from Desktop to BB, but no success.

Some info about my board;

1) Board version : B7
2) Kernel verison : 2.6.28
Note:- I also tried using 2.6.26 , 2.6.27 and 2.6.29 but got the same
result.

When I plug in my USB adapter I get following error messages on
terminal.

Hi Amit,

What brand/model zd1211? I picked up a couple random ones from
newegg, but they turned out to be an other chipset (rtl8187 which i
already had and works, and one that just entered staging in 2.6.30)...

In theory, there is a fix, i just haven't been able to test it yet..

Would you please try:
http://www.rcn-ee.com/deb/kernel/beagle/jaunty/v2.6.29-58cf2f1-oer39.1/

Use this uImage:
http://www.rcn-ee.com/deb/kernel/beagle/jaunty/v2.6.29-58cf2f1-oer39.1/uImage
and install these modules:
http://www.rcn-ee.com/deb/kernel/beagle/jaunty/v2.6.29-58cf2f1-oer39.1/linux-image-2.6.29-oer39.1_1.0jaunty_armel.deb

Regards

Hi Robert,

Thanks for the reply ... I will try the links you posted.
I have USB wi-fi adapter from my essentials
Model No: ME1001-USB
link: http://www.myessentialssupport.com/product/?pid=ME1001-USB#

I am not sure about the chipset. I tried calling customer support
but ... they are not willing
to tell the chipset used.

Thanks,
Amit

Hi Robert,

Can u tell me how to install the module u suggested on BB.

and install these modules:
http://www.rcn-ee.com/deb/kernel/beagle/jaunty/v2.6.29-58cf2f1-oer39

Thanks,
Amit

Hi Amit,

sudo dpkg -i linux-image-*.deb

(hopefully your using an ubuntu root filesystem. not sure Angstrom
will install it..)

Regards,

Thanks, Amazon had it in stock, so I'll be able to test it
Monday/Tuesday night..

Regards,

Robert Nelson wrote:

but I need it to angstrom

Hi Diego,

Please read, (its in Portuguese) :
http://www.celiojunior.com.br/comofazerperguntas.php

thats more than one page!!!!!

Hi,
I tried the uImage u send me. But it failed to recognize any of the
USB devices connected to my
USB HUB. I think this is the problem with kernel verison 2009. I faced
this problem previously with 2.6.29 kernel verison.

I couldn't install the module as I am working on Angstrom filesystem.
I dont prefer ubuntu because its very very very slow with BB ver7. I
dont know if this is the
problem in general or specific to my board. But I will try to follow
your instructions with ubuntu

thanks,
Amit

It's the only translation i could find...

This is the section i'm hoping he reads:
http://catb.org/~esr/faqs/smart-questions.html#beprecise

Regards

Actually you could use this with Angstrom...

dl file on debian based pc..

dpkg -x linux-image* ./temp

then copy ./temp to your Angstrom sd card... (need /lib/modules/2.6.29.../)

Regards,

Hi Robert,

I did,
dpkg -x linux-image* ./temp and copied the contents of ./temp on bb
at
/lib/modules/2.6.29-omap1/

i.e. I copied all three folders in ./temp at the above location ( i.e.
boot, lib and usr)
But event this didnot recognized USB devices with 2.6.29 kernel and
hence could
not get wi-fi working.

Just for info ... what this module is supposed to do.

Thanks
- Amit

Hi Amit,

Just the lib should have been fine..

During bootup, that uImage should be looking for: /lib/modules/2.6.29-oer39.1/

/lib/modules/2.6.29-oer39.1/kernel/drivers/net/wireless/zd1211rw/zd1211rw.ko

I'm guessing it still needs a little more work, so we will see early
next week, when the modules arrives...

Regards,

Robert Nelson wrote:

Robert Nelson wrote:

   but I need it to angstrom

Hi Diego,

Please read, (its in Portuguese) :
http://www.celiojunior.com.br/comofazerperguntas.php

thats more than one page!!!!!

It's the only translation i could find...

This is the section i'm hoping he reads:
How To Ask Questions The Smart Way

and it does not hurt to actually read it all :wink:

Hi Robert,

Currently I am working on Ubuntu to try ur instructions and see if I
get any success.
I try to find out the chipset used in my usb dongle ( ME1001-USB) and
I guess its from Realtech

Any suggestion on the drivers required for realtech chipset.
I was just thinking to try with rtl8187 drivers. Can you tell me from
where can I
get those drivers.

Thanks,
Amit

Hello,

The rtl8187 drivers are actually built into the kernel already...

This is from digitus usb adapter we use to sell at digikey..

[ 545.775503] phy0: hwaddr 00:18:e7:32:a2:68, RTL8187vB (default) V1
+ rtl8225z2
[ 545.775543] usbcore: registered new interface driver rtl8187

0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter

Your ME1001-USB should be zd1211rw based:

https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported
myessentials
ME1001-USB
ID 050d:705c Belkin Components zd1211rw

Regards,

Hi Robert,

May be thats what I thought.
But when I did lsusb it showed me device type as Belkin components
F5D7050 v4000 wireless Adapter.
I dont know exactly what driver should be used with this. I am
googling to get some info.

Thanks,
Amit