Help Needed in Installing ftdi and usb driver file on ubuntu for beagleboard rev c4 with arduino

Hi
I m interfacing the arduino board with beagleboard using the usb
communication and i need to install two .ipk files on ubuntu... I got
a link to do but it is only for Angstrom distro please help me out in
ubuntu (armel) ... when i try to connect the arduino board, it says"
unable to enumerate the usb device on port 2".. what will be the
problem.. help plz

this is the link the procedure for doing at angstrom distro,
http://antipastohw.blogspot.com/2010/06/two-open-source-worlds-collide-using.html

Two files namely

1. usbserial.ipk
2. ftdi.ipk

these package files are actually consists of ftdi_sio.ko and
usbserial.ko files.. i dont know how to talk with beagle(ubuntu). when
i use insmod, it says like unknown module format .. so help me in this
issue...

Thanks a lot for reading...

-Vino

hi vinod,
you need to verify first your kernel version and drivers .ko of packages are the same.use modinfo and uname command.
if both are same then think to use same packages.
else you need to compile these drivers for you kernel version and then do insmod for these driver.

thanks,
amol

Downloading kernel modules from the internet usually isn't a good idea.
Kernel modules must be compiled for the specific kernel version and
variant that you're running, otherwise they won't load. They really need
to be built from the same tree to make sure all the options are the same
in the modules as they are in the running kernel.

So that said, if you're running an Angstrom-built kernel you want to get
modules which match it from opkg. The way to start is to run "opkg list"
(probably catting it to a file) and look for what you need. In your
case, you'll see a package called kernel-module-ftdi-sio. Once you've
found that, install it with:
    opkg install kernel-module-ftdi-sio

That's all I needed to do to make it work on mine. The /dev/ttyUSB*
serial ports show up automatically when you plug your device in once
you've installed the module for it.

Alan.

opkg is not working, it says 'bash: opkg: command not found'... what
to do for this and insmod is also not working.. help me plz,

thanks
Vino

On Ubuntu
sudo apt-get install libftdi-dev libftdi1 libftdipp1
It is enough installing these to communicate with arduino’s usb.

as well check you have alreday build that driver in kernel using modinfo command.if it is in kernel then no need to have seperate module.