Help needed to make Realtek 8191SU USB WiFi stick work on Beaglebone

Hi Folks,

After a few days of struggling I confess I am confused, and stuck. I need some help. (I am a newbie…)

I have a USB2 WiFi dongle, containing a Realtek RTL8191SU 802.11n WLAN Adapter chip. I would like to use it on my recently acquired Beaglebone card.

I am unable to find the appropriate firmware files for the Realtek RTL8191SU USB WiFi adapeter. Once I find them I believe they go in /firmware/rtlwifi but I have searched high and low and so far I am unable to find them. I also seem to be having some problem getting the board to see wlan0.

Any help or tips are welcome.

— details —

Since the beaglebone card was new, I did an “opkg update”, followed by “opkg install”, which ran for an hour or two installing fresh modules. There were a few errors which I found answers to elsewhere on this forum, and consequently they were fixed.

I ensured the wireless-tools package was installed properly, since previously the iwconfig command was unrecognized. After the install, the wireless-tools package is now revision 1:29-r4 .

root@beaglebone:/# opkg install wireless-tools
Package wireless-tools (1:29-r4) installed in root is up to date.

I did an “lsmod”, and observed a module for r8712u was installed.

root@beaglebone:/lib/firmware# lsmod
Module Size Used by
r8712u 118788 0
g_mass_storage 24010 0
ipv6 210434 18

I did an iwconfig, but it appeared the wlan0 interface was non-functional. From reading different posts on the internet, I concluded I needed the firmware drivers for the USB stick. I was unable to find any ready-to-go for the Beaglebone. I did visit the Realtek website and download their linux driver package, but it appears it needs to be compiled, and currently I am unsure how to use the makefile as provided to recompile the drivers. It seems likely to me that someone out there has already done this, since its a pretty common chip.

Anyway, I then removed the r8712u module, intending to install it again hoping this might prompt my board to recognize the USB WiFi dongle, however after removal, I was unable to find the r8712u module to install it again. Things were not looking good, so I rebooted. Later once the beaglebone came up again, I ran lsmod again but now it seems there are no modules installed…

root@beaglebone:/lib/firmware# lsmod
Module Size Used by

Also, now when I run iwconfig, it appears no wlan0 device is detected.

root@beaglebone:/# iwconfig
lo no wireless extensions.
eth0 no wireless extensions**.**

Clearly I am out of my depth here. Does anyone have a suggestion about how to ensure the necessary modules get loaded? Does anyone have a suggestion about where I might pick up compiled Firmware object files for the Realtek WiFi chip? Any other tips are also welcome.

And yes, I am trying to understand makefiles, etc, sufficient to recompile the Realtek linux drivers from scratch, but I am finding it difficult going.


Eric Dormer

any solution in here? i am having kind of the same problem with another hardware .

Dunno where I've got the one I used successfully under 3.0.x kernels
But you can find some realtek firmwares here

The .deb file is no more than a tar file

I had no problem using a dlink realtek based usb adapter under 3.0.17+ and 3.0.25+ kernels