how to change/enable mode pin?
i ever change at “/sys/kerner/debug/pinctr/44e10800# pins”
but output is “invalid argument”

anyone know?

The config-pin utility (which relies on cape-universal) is the
simplest way to configure BeagleBone pins:

How are you planning to use the pins?


I use it for input/output infrared

Pada tanggal 13 Jan 2017 10.08, “Drew Fustini” <> menulis:

I'm afraid that's not enough information for me to help. It would be
helpful if you could post a schematic and a list of the parts that you
are using.


Example: default pin p8_3 is gmc_ad6 (mode0). I want to change that pin to mode7(gpio1_6)
How to change? I cant solve it…still mode0

Pada tanggal 13 Jan 2017 10.15, “Drew Fustini” <> menulis:

It seems that P8_3 is used by the eMMC by default. I am using Debian
8.6 (2016-11-27). When I first tried config-pin for that pin, I got
this error:

debian@beaglebone:~$ config-pin -q P8.3
P8_03 pinmux file not found!
cape-universala overlay not found
run "config-pin overlay cape-universala" to load the cape

I edited /boot/uEnv.txt to use dtb that disables eMMC and enabled

cmdline=coherent_pool=1M quiet cape_universal=enable

After rebooting, the cape-universala overlay is loaded:

debian@beaglebone:~$ cat /sys/devices/platform/bone_capemgr/slots
0: PF---- -1
1: PF---- -1
2: PF---- -1
3: PF---- -1
4: P-O-L- 0 Override Board Name,00A0,Override Manuf,cape-universala

P8_3 can now be set in GPIO mode with config-pin:

debian@beaglebone:~$ sudo config-pin -q P8.3
P8_03 Mode: default Direction: in Value: 1

debian@beaglebone:~$ sudo config-pin -l P8.3
default gpio gpio_pu gpio_pd

debian@beaglebone:~$ sudo config-pin P8.3 gpio

debian@beaglebone:~$ sudo config-pin -q P8.3
P8_03 Mode: gpio Direction: in Value: 1


If you have questions about what exactly to edit in /boot/uEnv.txt,
then please post the full contents of your /boot/uEnv.txt