How can I stop the display from automatically turning off?

Hello everyone.

I am using Angstrom (2.6.32) on a Rev C4 Beagle Board and the display (TI’s Pico Projector Dev Kit 2.0) seems to turn off automatically after some period of time, even while I am running an OpenGL ES program (but without any keyboard/mouse input). Also, this only happens maybe ~70-80% of the time–sometimes the display remains on. The display turns on again if I restart the program, but then later it turns off again. Why is the display shutting down and is there a way to prevent this from happening?

Thanks,

Jonathan

its the 1 minute auto blanking thing.
not sure if this helps

http://wiki.openmoko.org/wiki/Manual_Debian#Disable_Framebuffer_Blanking

KP

Thanks for the response. I managed to find more information about the terminal blanking here: http://e2e.ti.com/support/dsp/omap_applications_processors/f/447/t/37959.aspx.

I added “consoleblank=0” to the kernel boot arguments, and it seems to be working.

(The other options included: search for “blankinterval” in drivers/char/vt.c and modify the value; and use the command “echo 0 > /sys/class/graphics/fb0/blank” to cancel the blanking after it occurred)

Jonathan