How do I disable I2C2 on BBB Jessie?

Hi all,

I’ve been working with both of the CAN bus interfaces on the BBB, which meant disabling I2C2 to get the pins back. Under Wheezy this was fairly straightforward, following the instructions here:

http://www.embedded-things.com/bbb/enable-canbus-on-the-beaglebone-black/

I can’t find a Jessie equivalent anywhere and the way these things work seems pretty different now. Can anybody help please?

Cheers,

Ben.

First of all compare his files with those of the bb.org-overlay git.

These two lines : https://github.com/beagleboard/bb.org-overlays/blob/master/src/arm/BB-CAN1-00A0.dts#L13-#L14 are missing from his files, and is fragment is different than this: https://github.com/beagleboard/bb.org-overlays/blob/master/src/arm/BB-CAN1-00A0.dts#L43-#L49

Granted, this is for dcan1, but if you setup a file for dcan0 like this, but with dcan0 pinmux etc. Technically it should just work. However, I do not recall off hand what’s connected to I2C2, so you need to investigate that yourself.

Additionally, i2c2 is enabled here: https://github.com/RobertCNelson/dtb-rebuilder/blob/4.1-ti/src/arm/am335x-bone-common.dtsi#L257

You should really find out what the impact of disabling i2c2 in the device tree files before doing so though.

Hi Ben,

Do you get success in disabling i2c2.
I have same problem, could u guide me to overcome this issue

Thanks