How do I get a response from the USB Port on BeagleBone Black

I have the Debian distribution of Linux. I ran lsusb and read two Buses, 001 and 002. Both are listed as root hubs. I have tried plugging in a Dell LED mouse as well as Bluetooth dongle and even a different dongle. I know all three USB devices are operational. The mouse did not even light up,

I did use an external power supply in case I had issues. I am communicating with the BeagleBone Black via Putty and through the USB micro connector. I have not problem there. It appears to be the second USB port that just sits there. Any advice? I thought the drivers were supposed to download automatically.

I did plug in a powered USB hub. When I did this and ran lusb I was able to see the hub identified. Plugging in a mouse in still gets no LED to light. What am I doing wrong?

How old is this BeagleBone Black?

usb hotplug was broken initially, fix-ish later a kernel update..

The usb devices should work when plugged in before power up.

and when using any usb devices, make sure you are powering the board
via the 5volt dc barrel.