How does one find the TCP address of a BBB ?

Greetings to all :slight_smile:

I received my new BBB (Beaglebone Black, Revision A6) and was following the startup directions.

My Windows 7 x64 PC recognized the BBB when I plugged in the USB cable and it assigned a drive letter to the new device.

I downloaded and ran the USB driver installer (BONE_D64.exe), it ran and completed with no problems.

I added a TCP address alias, to enable my computer to talk on 192.168.7.xxx subnet.

I hooked up an ethernet cable between my BBB & my network hub, and tried to access the web page at 192.168.7.2 as directed.
My Firefox browser times out and gives me an error page stating:
"The connection has timed out"
The server at 192.168.7.2 is taking too long to respond."

I have tried using the “Advanced IP Scanner” utility to scan the 192.168.7.0 through 192.168.7.255 address range and no devices, other than my computer, shows up.

Is there a recommended TCP/IP network scanner that would be able to find my BBB ?

Thank you in advance for any & all help.

Jonmar

subnet mask 255.255.255.0

default gateway 192.168.7.1

Under settings for that network device. You may even need to enter the BBB’s IP for the DNS server(s).

I just tried accessing the tcp/ip address 192.168.7.1 and it also times out.

As I posted previously, using the “Advanced IP Scanner” program, I scanned the entire address range of 192.168.7.1 through 192.168.7.255 with no devices being found except my PC.

At present, I do not know how to access the network device settings on the BBB :frowning:

Thank you for trying to help William.

Jonmar

Jonmar,

Well, you’re not exactly being clear as to what exactly you have under your networking settings for the USB device. On the Windows side.

We need to know( on the windows side ) . .

  1. What ip address you gave the interface( you already stated )

  2. what subnet mask are you using( not stated )

  3. what is the default gateway set to.( also not stated ).

Just typing in an IP address for the interface is not going to do anything.

I hooked up an ethernet cable between my BBB & my network hub, and tried to access the web page at 192.168.7.2 as directed.

To communicate with the BBB at 172.168.7.2 no Ethernet cable is needed. USB connection only.
(ans as far as I remember, not any Windows LAN configuration - everything goes PNP at USB driver installation)

Another case should be if you connected 2 or more BBBs… :slight_smile:

Keep in mind that if you have a serial debug cable, then you can monitor the BBB boot messages, during which it displays all of the configured network interfaces (among much other stuff).

http://www.elinux.org/Beagleboard:BeagleBone_Black_Serial

-Chris

Okay …

I disconnected the ethernet cable and only have the USB cable (the USB-A to micro-usb cable[plugged into P4] that came with my BBB) connected to my BBB.

I tried accessing both 192.168.7.1 & 192.168.7.2 and both web page accesses timed out :frowning:

I have only the one BBB that I am trying to get functional.

Any other suggestions ?

Jonmar

I have a FTDI adapter-cable at home, that I bought for working with Arduinos, that I will retreive and try to see what messages are displayed.

Thanks for the tip.

Jonmar

if it’s 5v it wont work.