how to choose the correct Linaro toolchain v* ?

Hi,

It has always been a problem for me, how do you choose the correct version of linaro toolchain ?

The problem with a wrong toolchain for your machine is for debuging:

warning: .dynamic section for “/home/LinuxDev/toolchain/gcc-linaro-arm-linux-gnueabihf-4.9-2014.09_linux/arm-linux-gnueabihf/libc/lib/arm-linux-gnueabihf/libpthread.so.0” is not at the expected address (wrong library or version mismatch?)

But maybe it can be a problem if a function don’t exist in an older libgcc

My last idea was to check GCC :

I’m on a kernel 3.8 machine : gcc version 4.6.3

So I need at least a toolchain that have gcc 4.6.3 ?

I guess that the correct toolchain is :

https://releases.linaro.org/13.05/components/toolchain/gcc-linaro/4.6

Am I correct ?

Micka,