How to.disable HDMI on Beagle Board Black with "bone-debian-8.6-iot-armhf-2016-11-06-4gb.img"?

I have downloaded “bone-debian-8.6-iot-armhf-2016-11-06-4gb.img” from “https://beagleboard.org/latest-images”, burned it into a microSD card, turned the card into a flasher, and flashed a Beagle Board Black with it.

I understood reading “/boot/uEnv.txt” that enabling the following line should disable the HDMI pins:
dtb=am335x-boneblack-overlay.dtb

However, when I reboot the Beagle Board, this is what I get:
<<

Loading, please wait…
mount: can’t find /root in /etc/fstab
Target filesystem doesn’t have requested /sbin/init.
mount: mounting /dev on /root/dev failed: No such file or directory
No init found. Try passing init= bootarg.
modprobe: module i8042 not found in modules.dep
modprobe: module ehci-pci not found in modules.dep
modprobe: module ehci-orion not found in modules.dep
modprobe: module uhci-hcd not found in modules.dep
modprobe: module ohci-hcd not found in modules.dep

BusyBox v1.22.1 (Debian 1:1.22.0-9+deb8u1) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

/bin/sh: can’t access tty; job control turned off
(initramfs)

What did I do wrong?

Turning the microSD back into non-flasher mode, booting the Beagle Board from it and making the same change in “uEnv.txt” works without any problem: the Beagle Board boots up and the the HDMI pins are now available for other uses.

that also disables the eMMC...

use:

dtb=am335x-boneblack-emmc-overlay.dtb

Regards,