How to disable SoftAp0?

Hi all,

I’m trying to set up a BeagleBone Black as a Pi-Hole server, and I’ve run into an issue that I can’t quite figure out; Pi-Hole is basically a layer over dnsmasq to make it easier to use.
The issue is that the BeagleBone’s SoftAp0 interface has a cache-size line in /etc/dnsmasq.d/SoftAp0 which conflicts with a cache-size line in /etc/dnsmasq.d/01-pihole.conf.

I’ve tried the advice here, setting both TETHER_ENABLED and USE_GENERATED_DNSMASQ to “no”, but upon every reboot, something continues to restore SoftAp0 to its default contents, which breaks Pi-Hole due to the duplicated “cache-size”.!newtopic/beagleboard/beagleboard/ggNeXEq9SUA

Other than /etc/default/bb-wl18xx, is there something else that controls the contents (or existence) of /etc/dnsmasq.d/SoftAp0? I’m using a non-wireless BBB that is hard-wired to my network, so I really don’t need any wireless functionality on this board at all.

It’s also done here.



That fixed it, thanks! Just commented out the one line in that mentioned SoftAp0.