How to enable SPI on PocketBeagle + Kernel 5.10


I’m trying to use Pocketbeagle with kernel 5.10 but the spi is not enabled. I flashed the image bone-debian-10.13-console-armhf-2022-10-10-1gb.img.xz
How can I enable or what kernel version I should use to have the spi enabled ? I’m tried two rt kernels -
5.10.140-bone-rt-r68 and 5.10.140-ti-rt-r52.



Is /dev/spidev* not located in where it is normally? If indeed it is not located there for some reason, try /dev/bone/spi/*.


Hi Seth,

I need to manually load the spidev module (lsmod spidev) and the spi was correctly created.

1 Like