How to enable UART1 using dtb-rebuilder?

I was able to enable all the UART serial connections on my BBB before I switched to the last kernel.
In the following tutorial it was explained very well, how to change the cape-fuctions accordingly and everything worked fine.

Now I have the latest Ubuntu distro on my board. I ve downloaded the last dtb-rebuilder for 4.1-ti and try to enable again my old uart ports.
It seems that everything is changed since 3.8. I open my am335x-boneblack-dts, but I can find any
#include

directive which helps to activate/deactivate peripherals.

The readme in the repository says nothing about that.

What should I do?
How can I compile my dtb-file for my board?

4.1-ti supports overlays, so you can either do it like "3.8".

https://github.com/beagleboard/bb.org-overlays/blob/master/src/arm/BB-UART1-00A0.dts

or create a custom *.dtb

Regards,

4.1-ti supports overlays, so you can either do it like “3.8”.

https://github.com/beagleboard/bb.org-overlays/blob/master/src/arm/BB-UART1-00A0.dts

or create a custom *.dtb

That’s nice,
but I cannot find any guide that helps me to install the new cape like in the first tutorial I posted above.

How do I use such overlays?
https://github.com/beagleboard/bb.org-overlays/blob/master/src/arm/BB-UART1-00A0.dts

Should I copy them somewhere?

Follow steps 1 -> 3:

https://github.com/beagleboard/bb.org-overlays/blob/master/readme.md

Then either:

sudo sh -c "echo 'BB-UART1' > /sys/devices/platform/bone_capemgr/slots"

or:

/boot/uEnv.txt

cape_enable=bone_capemgr.enable_partno=BB-UART1

Regards,

http://www.embeddedhobbyist.com/2015/09/beaglebone-black-updating-device-tree-files/

Thank both of you.

Your explanations did work very well and I can load capes without a problem.

The only problem is that no capes are loaded at boot startup process. So I need to load the cape everytime.
The following answer didn’t help further. I have that flag as default in my beagle.

The only working way seems to be:

`
/boot/uEnv.txt // open that file and write the following:

cape_enable=bone_capemgr.enable_partno=BB-UART1
`

But I thought that this is just an alternative, not the first choice.

Any idea?